The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/vdomainaliases stealing email

Discussion in 'E-mail Discussions' started by ladydi711, Mar 17, 2017.

  1. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    129
    Likes Received:
    3
    Trophy Points:
    318
    Hi,

    I hope I can explain this correctly.

    I have an account on my server, but have deleted the domain zone file for it as it is managed elsewhere, and I am not hosting it's email.

    However, when trying to send an email to a valid email address for the domain from my server, it seems that it is getting caught by my server as a domain forwarder.

    2017-03-17 09:40:04 1cot2y-00025I-Kh ** user@hisdomain.com <user@hisdomain.com> R=virtual_aliases: No such person at this address.

    There is an empty file in /etc/vdomainaliases/hisdomain.com.

    Is the solution to delete that so I can send him mail from my server? Or is there a more elegant way through cPanel/WHM.

    Thanks In Advance!!
     
  2. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    The problem is the server thinks its a local domain meaning its trying to route email sent locally from the server to the same server, its not bothering to check the MX record since the domain resides on the server.

    Remote the domain from

    /etc/localdomains

    and add the domain to

    /etc/remotedomains

    You'll be good to go.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You'll need to re-create the zone file for the domain name, as that's where the email routing configuration is stored. Once you have created the zone, browse to "WHM >> Edit DNS Zone", select the domain name, and edit the "Email Routing" settings to use "Remote Mail Exchanger".

    Thank you.
     

Share This Page