The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/etc/vfilters/domain.tld — incorrect owner group

Discussion in 'General Discussion' started by Vasily L., Jul 16, 2015.

  1. Vasily L.

    Vasily L. Registered

    Jul 16, 2015
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello cPanel gurus,

    Kindly asking for your assistance.

    I've encountered weird issue while working with vfilters feature lately.

    For example, I have domain.tld with user domaint. When I try to enable Auto Delete Spam in the user's control panel, it returns the following error:

    Write Failure: /etc/vfilters/domain.tld
    The system failed to write to the configuration file.


    [2015-07-17 01:11:18 +0800] warn [Email::addspamfilter] Encountered error in Email::addspamfilter: Error:
    Write Failure: /etc/vfilters/
    The system failed to write to the configuration file.
    [2015-07-17 01:11:19 +0800] warn [Email::enable_spam_autodelete] Encountered error in Email::enable_spam_autodelete: Error:
    Write Failure: /etc/vfilters/

    I went to check the permissions, and it was just fine, 711 and stuff:

    drwx--x--x 2 root root 4096 Jul 17 03:21 /etc/vfilters/

    I have even compared this to other cPanel servers I have in my cluster, all perms are identical.

    However, being not able to find out what's wrong, I tried assigning 777 to /etc/vfilters, and then it worked, file created successfully:

    -rw-r--r-- 1 domaint domaint 808 Jul 17 01:44 domain.tld

    The first this I noticed is that owner group for this file is not correct, should be 'mail' instead of just user. I've checked with other cPanels and it was confirmed, all files are created with 'mail' owner group.

    The thing is that I did not found any settings regarding this, or any option on how to change the default owner of the newly created filter files. Only single server is affected and as I mentioned before, settings are identical and applied via Puppet.

    Where do I go next? What do I need to check? Is there a thing I am not aware of? Please send help :)

    My cPanel / WHM is 11.50.0 (build 23)

    Thanks for your help in advance.

    #1 Vasily L., Jul 16, 2015
    Last edited by a moderator: Jul 16, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you create a test account through Web Host Manager, and then create a filter for that account? Check to see if the new file in the /etc/vfilters directory also uses invalid ownership, or if it's only the existing files in the directory.

    Thank you.

Share This Page