Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Evaluating sitezen; needs system() enabled; looking for recommendations on best pract

Discussion in 'General Discussion' started by stardotstar, Jan 21, 2010.

  1. stardotstar

    stardotstar Well-Known Member

    Joined:
    Sep 14, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    56
    Hi all,

    I am running suphp with cP/WHM on my Centos host.
    In evaluating the sitezen site builder software I have come across an error when a customer (or anyone) launches the sitebuilder software from the icon installed into cP.

    This is because the system() function needs to be enabled in php.ini - or not excluded by the disable_functions entry...

    I have not done anything to try and resolve this - ie enabling it in the system wide php.ini because I found that I couldn't determine where in the user account system (user's homes) I could add a modified php.ini that would work - I expect because the cP works outside of the constraints of the user's php.ini with respect to suphp...

    I don't want to open a can of worms from a security pov.

    Their support response is:

    What can anyone recommend as a way of enabling the calls this site builder needs with a minimal/acceptable impact on security?

    Many thanks in advance,
    Will
     
  2. stardotstar

    stardotstar Well-Known Member

    Joined:
    Sep 14, 2009
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    56
    Anyone give me a hit on this one?
    Cheers,
    W
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice