The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Excessive resource usage: xfs (4324) ??

Discussion in 'General Discussion' started by bigste, May 2, 2011.

  1. bigste

    bigste Member

    Joined:
    Jan 6, 2009
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cheshire, UK
    since last week I'm getting a lot of these alerts from lfd, maybe one every hour:-


    Time: Wed Apr 27 15:17:03 2011 +0100
    Account: xfs
    Resource: Process Time
    Exceeded: 1853 > 1800 (seconds)
    Executable: /usr/bin/xfs
    Command Line: xfs -droppriv -daemon
    PID: 4290
    Killed: No


    does anybody know what it means and should I be worried about it?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    xfs is a journaling system and should likely be excluded from these alerts, since it would run beyond 1800 seconds (it isn't high CPU or memory it is using, but simply running a long time per the alert).

    Please note that LFD is a third-party product provided by ConfigServer Security & Firewall:

    ConfigServer Scripts Forum • Index page

    Posting on that forum for any alerts produced by their third party product might be more beneficial, since they will know how to exclude set commands and processes from triggering an alert.
     
  3. bigste

    bigste Member

    Joined:
    Jan 6, 2009
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cheshire, UK
    yes, I realise that LFD is a third party product and I agree, a solution to solving the alert may be found on the ConfigServer Forum, however, I was hoping to find out why it would have suddenly started causing an alert.
    I'm not familiar with xfs, it seems odd that it should have just started up by itself.
    Are there any cPanel processes that may have enabled this journaling system that I could investigate?
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
  5. bigste

    bigste Member

    Joined:
    Jan 6, 2009
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cheshire, UK
    I haven't recently installed X or opted to use it at anytime, is there anything new in cPanel that could have triggered this.
    I only ever use the command line interface.
    Does this suggest that an Xserver session could be running in the background?
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    XFS is often installed as a dependency for various packages. For example, RRDTool (which generates the various bandwidth graphs in the cPanel Bandwidth UI) requires various font and display libraries. It is rather common for one of these to pull in the XFS package as a dependency. Likewise a standard installation of CentOS, or RHEL, will often result in XFS being installed.

    This does not mean X is running.

    You can usually stop xfs via the following command on the command line:

    Code:
    # /etc/init.d/xfs stop
    
    Also, you can prevent XFS from being started upon boot by issuing the following command on the command line:
    Code:
    # chkconfig xfs off
    
    To confirm XFS will not start on boot (or just to see what runlevels it is enabled for), issue the following command:

    Code:
    # chkconfig --list xfs
    
    You will see output like:
    Code:
    # chkconfig --list xfs
    xfs            	0:off	1:off	2:on	3:off	4:on	5:off	6:off
    
    The above commands need executed by root in order to take effect.
     
  7. bigste

    bigste Member

    Joined:
    Jan 6, 2009
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cheshire, UK
    Great response Kenneth, and very well documented.

    Thanks for that.
     
  8. kschaef65

    kschaef65 Registered

    Joined:
    Jun 15, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    This was very helpful. Thanks for posting.
     
Loading...

Share This Page