Exchange Online Cpanel Hybrid

Gerald KIG

Registered
Jun 1, 2021
1
0
1
Austria
cPanel Access Level
DataCenter Provider
I need help. I have added my primary cPanel domain to Exchange Online so I can Host some Mailboxes at Microsoft. MX Record of primary domain is still pointing to cPanel Server. I accomplished a working mail routing with forwarders on cPanel to a second domain I have already configured in Exchange Online. So mails are getting forwarded fine for my primary domain and all users in Exchange Online can also send mails externally to other domains (for example gmail.com). But if a user in Exchange Online with my primary domain sends a mail to user with a mailbox in cpanel (same primary domain) I get a NDR with error code "550 5.0.350 Remote server returned an error -> 550 smtp auth required". Other User with the second domain in Exchange Online" can send mails to cpanel primary domain mailboxes without any problems. I added a connector for that to work so no mail loop in Microsft world is happening. so mail routing is working but cpanel does not accept mails from same domain as his primary domain.

help would be appreciated
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Hey there! That's the correct behavior for the configuration you've described. There have been a few forums threads lately on this, and this one gets some search traffic still:


but in general, this is not something that is supported. It would be best to have all messages sent to one location or the other.