The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Execute MemoryError

Discussion in 'General Discussion' started by kinsky, Jan 31, 2007.

  1. kinsky

    kinsky Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    here is the output of Update System Software (WHM 10.8.0 cPanel 10.9.0-C131
    Fedora i686 - WHM X v3.1.0)

    Ftp Setup Script Version 6.0
    Fetching version information from http://updates.cpanel.net/ftpinstall/version (CURRENT)....Fetching http://updates.cpanel.net/ftpinstall/version (0)....@198.66.92.150......connected......receiving...100%......Done
    Done
    This is the pure-ftpd 1.0.21 installer release number 0.tls for platform fedora 4
    pure-ftpd is up to date. Use ftpup --force to force a reinstall
    MySQL Setup Script Version 7.0
    Loaded cPPkgs::MySQL ok!
    This is the cPPkgs::MySQL 5.0.27 installer for Linux.
    MySQL 5.0.27 is up to date
    Install Complete
    portsentry is up to date (Wed Jan 30 09:02:40 2002)
    Using newyum support...
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
    File "/usr/share/yum-cli/yummain.py", line 92, in main
    result, resultmsgs = do()
    File "/usr/share/yum-cli/cli.py", line 464, in doCommands
    return self.installPkgs()
    File "/usr/share/yum-cli/cli.py", line 830, in installPkgs
    self.doRepoSetup()
    File "/usr/share/yum-cli/cli.py", line 75, in doRepoSetup
    self.doSackSetup(thisrepo=thisrepo)
    File "__init__.py", line 260, in doSackSetup
    File "repos.py", line 287, in populateSack
    File "sqlitecache.py", line 96, in getPrimary
    File "sqlitecache.py", line 83, in _getbase
    File "sqlitecache.py", line 76, in getDatabase
    File "sqlitecache.py", line 49, in loadCache
    File "/usr/src/build/539311-i386/install//usr/lib/python2.4/site-packages/sqlite/main.py", line 244, in execute
    MemoryError

    How to fix that ? :confused:

    If I saw use 'top'
    up2date and yum always took 99% of process and almost use all of avaliable memory including swap
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you running that on a VPS or a real server? How much physical RAM do you have if it's a real server? If it's a VPS it would suggest you're running out of your memory allocation, or possibly that your yum installation is having problems.
     
  3. kinsky

    kinsky Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    I use real dedicated server with 1 Gb memory... I never have this problem before 8 January 2007...

    I try googling and i have one solution upgrade python-sqlite from 1.1.6 to 1.1.7 and here is the output of system update server software :

    Ftp Setup Script Version 6.0
    Fetching version information from http://updates.cpanel.net/ftpinstall/version (CURRENT)....Fetching http://updates.cpanel.net/ftpinstall/version (0)....@198.66.92.150......connected......receiving...100%......Done
    Done
    This is the pure-ftpd 1.0.21 installer release number 0.tls for platform fedora 4
    pure-ftpd is up to date. Use ftpup --force to force a reinstall
    MySQL Setup Script Version 7.0
    Loaded cPPkgs::MySQL ok!
    This is the cPPkgs::MySQL 5.0.27 installer for Linux.
    MySQL 5.0.27 is up to date
    Install Complete
    portsentry is up to date (Wed Jan 30 09:02:40 2002)
    Warning, could not load sqlite, falling back to pickle
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Nothing to do

    Complete

    well perhaps it works.. and now i can run easyapache as well..

    is there other solution to fix my problem ?

    thank you
     
    #3 kinsky, Jan 31, 2007
    Last edited: Jan 31, 2007
Loading...

Share This Page