The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim 4.20 and Interchange

Discussion in 'General Discussion' started by Curious Too, Jun 21, 2003.

  1. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Interchange users (version 4.9) are not able to receive their orders via email:

    Error during creation of order routing copy_user:
    Error while interpolating page etc/mail_receipt:
    Can't call method "mail" on an undefined value at /usr/local/cpanel/3rdparty/interchange/lib/Vend/Util.pm line 2269.
    Error sending mail to orders@domain.com:
    Can't call method "mail" on an undefined value at /usr/local/cpanel/3rdparty/interchange/lib/Vend/Util.pm line 2269.

    cPanel.net Support Ticket Number: 16447
     
  2. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
  3. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Yes, I have read it. The gist of their beef is with providers who offered Interchange without having any idea of how it operates. I have several customers who are successfully using Interchange with cPanel and am able to support them when necessary.

    A downgrade to Exim 3 fixed the mail problem with Interchange and Pine.

    cPanel.net Support Ticket Number:
     
  4. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    I think that they also said on their main page of their site that there's a problem with the version of the Perl module SQL::Statement that is included with cPanel that is not compatible with interchange and that's another reason why they are not supporting cPanel users.

    Also paid software should be donating some of their proceeds when they use open source software like that.

    Anyway thanks for sharing with us how you got interchange working.

    I had more problems with Exim 3 so I think that I'll stick with 4.
     
Loading...

Share This Page