The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim 4-24 Deny over quota option doesnt work

Discussion in 'General Discussion' started by markie, Oct 29, 2003.

  1. markie

    markie BANNED

    Joined:
    Oct 5, 2003
    Messages:
    143
    Likes Received:
    0
    Trophy Points:
    0
    The option, "Discard emails for users who have exceeded their quota instead of keeping them in the queue", when checked, still allows over quota email to arrive to the server. The end result is that the msgs get stuck in the queue for our over quota users.
     
  2. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    same here ..been scratchin' my head for weeks on this one.
     
  3. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    Did you guys ever get this option to work? I have trouble using the Exim Configuration feature in WHM when it's in Advanced mode. It seems to corrupt my custom SmartList configurations. So I can't use it. I have to manually edit the exim.conf file for it to not be corrupted.

    That being the case I don't know what setting in the exim.conf file is being modified to discard emails for users who have exceeded their quota instead of keeping them in the queue.

    Does anyone know what setting this is and how to enable it manually in the exim.conf file?
     
  4. ymfm

    ymfm Active Member

    Joined:
    Feb 21, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    same problem in all my servers.
     
  5. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    I made a thread a while back on it, didnt get a follow up on it from Cpanelor anything, but yea doesnt work for us either, Multiple O/Ss etc etc

    Far as I know it hasnt worked for many months, ive been putting it off on researching it but its starting to become a problem now.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've never seen a problem with it - works fine on all my servers. Are you sure you're not seeing queued bounce messages due to overquota accounts rather than actual email waiting to be delievered to an over quota account? They're quite different issues. What messages do you get when you try to deliver an individual item in the queue?
     
  7. ymfm

    ymfm Active Member

    Joined:
    Feb 21, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil
    you are correct, Chirpy. sorry.

    Now I see is the bounce message.
    When I try to deliver, it says there is no malbox
    ** qcqdid@msn.com R=lookuphost T=remote_smtp: SMTP error from remote mailer after RCPT TO:<qcqdid@msn.com>: host mx2.hotmail.com [65.54.190.7]: 550 Requested action not taken: mailbox unavailable

    The problem is that Cpanel keeps trying the delivery for 7 days.
    Is it possible to delete this kind of e-mail?
    It´s all from spam and it's bacaming worse everyday.

    Thanks a lot
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    ignore_bounce_errors_after should probably work. If you go into WHM > Exim Configuration Editor > Advanced Mode > and in the very first textbox add the line:

    ignore_bounce_errors_after = 12h

    Which should ditch the messages after 12 hours of trying to be delivered from the queue.
     
  9. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    1D8mfK-0001W0-Qz-D
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    contact@mack460cx.com
    mailbox is full

    mack460cx.com is an actual account on the server, this is what i was reffering to
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup, so that's a quota exceeded bounce, not mail waiting in the queue to be delivered to an overquota account. So exim is working correctly. You have the same issue as ymfm - have you tried my suggestion?
     
  11. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    Yep, tried your ignore_bounce thing, looked at the queue today and mail is still there, I added it yesterday morning, ill give it a few more hours incase...

    When you add this tag what does it do, stop delivering the mail or what?

    If this timeout_frozen_after is set to say 2 days or less, and with the ignore tag if it works, one would assume this could keep your mail queue somewhat tidy?
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would hope so with the timeout_frozen_after. After the time elapses it should just give up sending the mail and drop it. If this doesn't work, there is another idea mentioned on the exim mailing list where you can create a new director, so do let me know if it doesn't work.
     
  13. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    alrighty took a look at the queue its up another 1k ignore tag doesnt appear to work

    Does this apply to all transit rather its going in or out? Or just coming into the server from other networks
     
  14. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It should apply to any bounce error, but it may not include over-quota bounces.

    I've had a good trawl through the exim mailing lists without seeing a sound way around the issue (you could try asking on the list).

    One idea mentioned would be to do more advnaced sender checking. To do this, make sure that WHM > Exim Configuration Editor > Verify the existance of email senders is checked.

    Then go into the Andvaced editor and down to the first set of 3 textboxes and look at the text in the middle of these - this is the ACL section. Look for the line:

    require verify = sender

    And set it to use callout:

    require verify = sender/callout

    For an explanation of callout, read this:
    http://www.exim.org/exim-html-4.40/doc/html/spec_38.html#SECT38.20

    Note that this won't apply to existing bounces which you will need to delete from the mail queue manually.
     
  15. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    ive tried this once before and it actually caused problems for some people because the emails would bounce back to the user and they would complain to us saying our server is not sending out emails when we try to explain to them its attempting to verify etc etc so in the midst of it all I had to turn this off :(

    I appreciate your help non the less
     
  16. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    I think I've just experienced the opposite problem after sending out a mailing (Exim 4.44). In WHM, I have the following configured:

    • Discard emails for users who have exceeded their quota instead of keeping them in the queue is unchecked.
    • The maximum each domain can send out per hour was set to 300
    As soon as the system hit 300, all additional mail was returned to the sender address with the following.
    And I found the following in /var/log/exim_mainlog:
    Given the Discard settings above, I would have expected the extra messages to be placed in the queue. It did not - it discarded them after sending the bounce message which is opposite to what the check box suggests.

    Any suggestions? Thanks -
     
    #16 RickG, Apr 3, 2005
    Last edited: Apr 3, 2005
  17. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Nope, as soon as a domain hits that limit subsequent emails are always discarded.
     
  18. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    Jonathan:

    Your comment made me slow down and re-read the options.

    For some reason, I thought the ... maximum each domain can send out ... statement was related to the Quota. I.E. they exceed the maximum number, they are over quota.

    I get it these two options are unrelated and Quota referes to the user mailbox.

    Thanks for your response.
     
Loading...

Share This Page