The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim 4.34

Discussion in 'General Discussion' started by rmbnet, May 16, 2004.

  1. rmbnet

    rmbnet Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Since the upgrade to exim 4.34 I get the following error in paniclog.. any ideas?

    2004-05-16 15:11:02 1BPSuT-00063E-N9 failed to expand condition "${perl{checkspam}}" for literal router: Gid 12 is not permitted to relay mail at /etc/exim.pl line 346.

    thanks!
     
  2. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    I reported the same thing here, http://forums.cpanel.net/showthread.php?s=&threadid=24233&highlight=exim

    And what is checkspam anyway? Is CPanel checking our boxes and do us a favour now by checking for spam? Wow, i feel so priviliged!

    Did anyone bother responding when i posted it?
     
  3. rmbnet

    rmbnet Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Nope, no responses, reinstalled exim and I havent seen the error since.
     
  4. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    We already re installed Exim countless times!!!!
     
  5. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    checkspam is more than likely spamassassin. Try re-installing spamassassin or disabling it serverwide.
     
  6. mr.wonderful

    mr.wonderful BANNED

    Joined:
    Feb 1, 2004
    Messages:
    345
    Likes Received:
    0
    Trophy Points:
    0
    What? There is no checkspam pgm by spamassassin. Its a perl pgm by Cpanel. This issue is happening to every single one of our server including server we manage for others. Now howcome? This is an Exim 4.34.0 issue. I see it on Redhat enterprise as well as RH 7.2 and 7.3. :rolleyes:
     
  7. bradandersen

    bradandersen Active Member

    Joined:
    Oct 6, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Can't send local email

    Hello,

    When using OSCommerce to send email, it can't send emails to any outside hosts. Does anybody know what this perl{checkspam} thing is all about?

    Thanks,
    Brad

    Here are my exim_mainlog extracts:

    2004-07-01 01:58:57 1Bfub3-0006kk-Lj <= sales@indo-imports.com U=nobody P=local S=498
    2004-07-01 01:58:57 1Bfub3-0006kk-Lj failed to expand condition "${perl{checkspam}}" for lookuphost router:

    you are not permitted to relay mail at /etc/exim.pl line 497.

    2004-07-01 01:58:57 1Bfub3-0006kk-Lj failed to expand condition "${perl{checkspam}}" for literal router: you

    are not permitted to relay mail at /etc/exim.pl line 497.

    2004-07-01 01:58:57 1Bfub3-0006kk-Lj ** brad_s_andersen@hotmail.com R=fail_remote_domains: unrouteable mail

    domain "hotmail.com"
    2004-07-01 01:58:57 1Bfub3-0006km-P3 <= <> R=1Bfub3-0006kk-Lj U=mailnull P=local S=1391
    2004-07-01 01:58:57 1Bfub3-0006kk-Lj Completed





    2004-07-01 02:11:22 1Bfun3-0006xA-OS <= sales@indo-imports.com U=nobody P=local S=494
    2004-07-01 02:11:22 1Bfun3-0006xA-OS failed to expand condition "${perl{checkspam}}" for lookuphost router: you are not permitted to relay mail at /etc/exim.pl line 497.

    2004-07-01 02:11:22 1Bfun3-0006xA-OS failed to expand condition "${perl{checkspam}}" for literal router: you are not permitted to relay mail at /etc/exim.pl line 497.

    2004-07-01 02:11:22 1Bfun3-0006xA-OS ** brad_s_andersen@hotmail.com: Unrouteable address
    2004-07-01 02:11:22 1Bfun4-0006xC-Mx <= <> R=1Bfun3-0006xA-OS U=mailnull P=local S=1369
    2004-07-01 02:11:23 1Bfun3-0006xA-OS Completed
    2004-07-01 02:11:23 1Bfun4-0006xC-Mx => brad <sales@indo-imports.com> R=virtual_user T=virtual_userdelivery
    2004-07-01 02:11:23 1Bfun4-0006xC-Mx Completed
     
  8. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Re: Can't send local email

    Check in your whm settings, make sure nobody is allowed to send mails. This problem should go then.
     
  9. bradandersen

    bradandersen Active Member

    Joined:
    Oct 6, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Fixed!

    Okay,

    If you remove the file /etc/webspam then you should stop getting these errors. However, you now open yourself to web programs that can be hijacked for spam. Look at /etc/exim.pl line 497.

    Somehow, there needs to be a list of trusted users that the web email programs can use in the sender field to bypass the spam filter. I figured if I created an alias in /etc/valias/$domain it would fix it, but it didn't.

    Good luck,
    Brad
     
  10. bradandersen

    bradandersen Active Member

    Joined:
    Oct 6, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Better fix - Thanks!

    Okay,

    Under "Tweak Settings" in WHM I unchecked the following and now it is working great, even after I replaced /etc/webspam.

    Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)

    Thanks for the help,
    Brad
     
  11. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Re: Better fix - Thanks!

    Thats what i posted earlier :) Because of enabling this option in WHM the mails were failing. If you still want to disable nobody user mails, compile php with phpsuexec.
     
Loading...

Share This Page