The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim 4.60 and ratelimit

Discussion in 'General Discussion' started by fmalekpour, Jan 20, 2006.

  1. fmalekpour

    fmalekpour Well-Known Member
    PartnerNOC

    Joined:
    Dec 4, 2002
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Hello,
    Is any one know how to upgrade the exim to latest version 4.60? It comes with new "ratelimit" feature, useful to control mail bombers and massive mail senders.


    Thanks
    F.Malekpour
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    cPanel don't offer that version as yet, so you can't unless you can find a source rpm on cPanel's site and try and compile it yourself.

    In the meantime you could always look at using the smtp_accept_max_per_host command and use a dictionary attack ACL:
    http://www.configserver.com/free/eximdeny.html
     
  3. bmuthig

    bmuthig Member
    PartnerNOC

    Joined:
    Feb 15, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ann Arbor, MI
    cPanel Access Level:
    DataCenter Provider
    Outgoing rate limiting?

    We have a customer who is sending (legitimate) large batches of email that is killing exim and then the dedicated server... I'm having trouble finding good documentation on how to have exim just queue up messages so the server doesn't die and send them out only a few at a time. Basically what happens is it ends up spawning a ton of exim processes (like 200+) at once... does anybody have an real world examples of how to stop this behavior? Maybe I'm misunderstanding the exim behavior of spawning all the processes. Any help is appreciated.

    I have seen a couple options:

    queue_run_max = 10
    remote_max_parallel = 10


    But these don't seem to have affect the 200+ exim procs getting spawned when a batch is sent. Thanks!
     
  4. fleksi

    fleksi Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    To queue on high load average, try:

    queue_only_load = 5

    All emails should then be dumped to the queue if your load average is 5 or higher at the time of the relay.
     
  7. fleksi

    fleksi Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    16
    Any update for /scripts/eximup ?
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Visit the URL I already posted.
     
  9. bmuthig

    bmuthig Member
    PartnerNOC

    Joined:
    Feb 15, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ann Arbor, MI
    cPanel Access Level:
    DataCenter Provider
    Looks like new exim coming down the pipe...

    http://diff.cpanel.net/eximinstall/version

    Just as an FYI for anybody subscribed to this thread still. Anybody tried implementing some ratelimit rules yet? Successes? Failures?
     
  10. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Found this interesting thread on using the new ACL section added to default Exim config:

    ----------------------------------
    acl_connect:
    [% ACL_CONNECT_BLOCK %]

    # do not change the comment in the line below, it is required for /usr/local/cpanel/bin/check_exim_config
    #acl_smtp_notquit is required for this to work (exim 4.68)

    acl_notquit:
    [% ACL_NOTQUIT_BLOCK %]

    ----------------------------------



    http://www.gossamer-threads.com/lists/exim/users/73767?do=post_view_threaded#73767
     
Loading...

Share This Page