Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

exim-4.69-30_cpanel_maildir is already installed. Use --force to reinstall

Discussion in 'E-mail Discussion' started by nightaddix, Apr 26, 2012.

Thread Status:
Not open for further replies.
  1. nightaddix

    nightaddix Active Member
    PartnerNOC

    Joined:
    Jul 7, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    56
    Hello,

    cPanel fails to upgrade on a server w/ CentOS 5.8 due to the following :

    [20120425.221701] Detected version '11.30.6.6' from version file.
    [20120425.221701] Target version set to '11.32.2.24'
    [20120425.221701] Checking license
    [20120425.221701] License file check complete
    [20120425.221701] E Blocker found: Upgrades past 11.30 are blocked
    because your exim is older than 4.70 and eximup is disabled.
    [20120425.221701] ***** FATAL: An attempt to up/downgrade to
    11.32.2.24 was blocked. Please review blockers.
    [20120425.221701] E Detected events which require user notification
    during updatenow. Will send iContact the log

    I tried running /scripts/eximup but got this :

    root@server [~]# /scripts/eximup
    Installing maildir version of exim
    exim-4.69-30_cpanel_maildir is already installed. Use --force to reinstall.

    Exim updates aren't disabled according to /etc/cpupdate.conf :

    root@server [~]# grep -i exim /etc/cpupdate.conf
    EXIMUP=inherit


    I tried manually upgrading the RPM by running the following :

    root@server [~]# rpm -Uvh http://httpupdate.cpanel.net/exim/4.70-4/centos/5.8/exim-4.70-4_cpanel_maildir.i386.rpm
    Retrieving http://httpupdate.cpanel.net/exim/4.70-4/centos/5.8/exim-4.70-4_cpanel_maildir.i386.rpm
    error: Failed dependencies:
    libresolv.so.2(GLIBC_PRIVATE) is needed by exim-4.70-4_cpanel_maildir.i386
    perl(SafeFile) is needed by exim-4.70-4_cpanel_maildir.i386

    Can you please advise how I can upgrade Exim to 4.70 ? There's no file called /etc/eximupdisabled or /etc/eximupdisable. Thanks in advance.
     
  2. nightaddix

    nightaddix Active Member
    PartnerNOC

    Joined:
    Jul 7, 2008
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    56
    Re: exim-4.69-30_cpanel_maildir is already installed. Use --force to reins

    Hello,

    This was fixed by switching from the STABLE version to the RELEASE version and by running /scripts/upcp. Thread closed :)
     
Loading...
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice