Exim: 421 Lost incoming connection

hostmoon

Well-Known Member
Aug 4, 2004
52
0
156
I still get spamd crashes on a regular basis, but I'm not seeing the 421 errors. HOWEVER, when spamd does crash, emails get caught in the queue and they cannot even be forced to be sent, it just hangs up. Restarting exim only sometimes work, so I've resorted to just rebooting everytime I see spamd crashes now. Sad that my windows boxes now seem more stable than my linux boxes :(

dale
 

jameshsi

Well-Known Member
Oct 22, 2001
347
0
316
Do we see any progress cpanel did about this issue ?

I got 3 servers with capnel, and 1 is using MailScanner, and that one is OK, but the others are unstable since yesterday, spamd crashed all the time, I update cpanel,delete all the emails in queue,and spamd seems better now,but I am not sure if it will fail again, and the 421 Lost incoming connection or local delivery failed shows up again, can someone point out where the HOWTO is ?
 

hostmoon

Well-Known Member
Aug 4, 2004
52
0
156
jameshsi said:
So, you mean reboot will solve the problem ?
temporarily, yes. i have tried restarting exim, that sometimes works, but not always. usually emails get stuck in the queue with no apparent way out until a reboot.

dale
 

barwin

Active Member
Jan 5, 2004
37
0
156
Manhattan
Updating exim to the 4.51-3 update worked great for us. We have 4 cpanel servers and all running smoothly now with the latest exim.

This is what I ran:

/scripts/updatenow
/scripts/eximup
 

jameshsi

Well-Known Member
Oct 22, 2001
347
0
316
Thanks Pal, I will try it now, and let you know if my problem fix. :)

Basicly, after delete all the emails in Mail Queue and update cpanel, my spamd is not showing me red light, but sometimes, I still see something like :
[email protected] send to root

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected][COLOR=DarkSlateBlue]user-domain.com[/COLOR]
(ultimately generated from [email protected][COLOR=DarkRed]server.com[/COLOR])
local delivery failed

The following text was generated during the delivery attempt:

------ [email protected]
(ultimately generated from [email protected]) ------

An error was detected while processing a file of BSMTP input.
The error message was:

421 SMTP incoming data timeout - message abandoned

The SMTP transaction started in line 0.
The error was detected in line 3.
0 previous messages were successfully processed.
The rest of the batch was abandoned.
421 SMTP incoming data timeout - message abandoned
Transaction started in line 0
Error detected in line 3
 

shacker23

Well-Known Member
Feb 20, 2005
263
1
168
I had the same problem. /etc/localdomains and /etc/remotedomains needed to be chown root:mail and chomd 660. These perms were incorrect after running

/scripts/updateuserdomains
/scripts/mailperm

Fixed the perms and POP and SMTP are now working properly. Thanks.
 

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
Very interesting!

Our localdomains & remotedomains having root.root & 644 on them at every server of us and they are working well!

May anyone comment this?
 

nwilkens

Well-Known Member
May 4, 2006
59
0
156
Monroe MI
cPanel Access Level
DataCenter Provider
spamd timeout line 1086, BSMTP error

Was recieving BSMTP errors in exim_mainlog. and in maillog spamd timeout errors
This happened every 2.5 - 3 days, reboot was only cure.

I switched from TCP connection to UNUX domain sockets and it appears to be resolved.

so one of the options to spamd was --socketpath=/var/run/spamd.sock

and for spamc I added -U /var/run/spamd.sock

Hope this helps someone else.
 

ispro

Well-Known Member
Verifed Vendor
Apr 8, 2004
628
2
168
nwilkens said:
Was recieving BSMTP errors in exim_mainlog. and in maillog spamd timeout errors
This happened every 2.5 - 3 days, reboot was only cure.

I switched from TCP connection to UNUX domain sockets and it appears to be resolved.

so one of the options to spamd was --socketpath=/var/run/spamd.sock

and for spamc I added -U /var/run/spamd.sock

Hope this helps someone else.
Umm.. Interesting! Would like to test it later!

Where have you edited these options? Is it compatible with cPanel or you have used the hacks into init scripts?