The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim-465,587 service down

Discussion in 'E-mail Discussions' started by jndawson, Aug 18, 2015.

  1. jndawson

    jndawson Well-Known Member

    Joined:
    Aug 27, 2014
    Messages:
    103
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I decided to use CSF to run a security check. One of the suggestions was to use smtp_block in the firewall, which performs the same function as the smtp tweaks (blocks users other than root and mailman from using outgoing ports). Part of that suggests adding ports that Exim listens on (25, 587,465). So we did that, restarted CSF & Exim.

    Now we're getting alerts that exim-465,587 is down (Exim-465,587 Failed) and the service status shows the same. Doesn't say anything about Exim, but it is running and mail is flowing.

    The alerts say that Exim-465,587 is not a valid service name.

    We removed 465 & 587 from the firewall smtp blocking, restarted Exim. No change. Removed the smtp block from CSF, restarted Exim, but still get the same alerts (very annoying) and status is down.

    We did the same thing on 2 other cPanel boxes with no issues. Why did this happen and what can we do?

    UPDATE:

    Checked Service Manager and found that 'Exim Mail Server (on another port)' had 465,587 in there. Changed it 587, and Exim-587 is up (according to Service Status). Turns out that's what we had on the other cPanel boxes.

    So, why does 465,587 not work in Service Manager?
     
    #1 jndawson, Aug 18, 2015
    Last edited: Aug 18, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,683
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The ports you referenced should already listen for connections by default:

    Code:
     [~]# netstat -lnp | grep exim
    tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      14444/exim         
    tcp        0      0 0.0.0.0:465             0.0.0.0:*               LISTEN      14444/exim         
    tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      14444/exim         
    tcp6       0      0 :::587                  :::*                    LISTEN      14444/exim         
    tcp6       0      0 :::465                  :::*                    LISTEN      14444/exim         
    tcp6       0      0 :::25                   :::*                    LISTEN      14444/exim
    You should not have to enable these ports in the service manager.

    Thank you.
     
  3. jndawson

    jndawson Well-Known Member

    Joined:
    Aug 27, 2014
    Messages:
    103
    Likes Received:
    4
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I'm well aware of the default configuration. What I don't understand is why the Service Manager specifically says to use comma delimited port numbers, but won't handle more than one port:

    Exim Mail Server (on another port) Allow exim to listen on a port other than 25.
    Useful for providers that block port 25 (multiple comma delimited ports may be added).
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,683
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I'm unable to reproduce this issue on our 11.52 development builds. To clarify, I selected "Enabled" and "Monitoring" for "Exim Mail Server (on another port)" in "WHM >> Service Configuration >> Service Manager" and entered the following value:

    Code:
    26,27,28
    I confirmed Exim began listening on these ports, and no errors were reported in /var/log/chkservd.log. Are there any additional steps I should take to reproduce this issue?

    Thank you.
     
Loading...

Share This Page