The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim 503 errors?

Discussion in 'E-mail Discussions' started by drsprite, May 9, 2007.

  1. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    I have a user who is using webmail to send email to a domain that has their MX records and website hosted through me which points to their Exchange. when they send an email they get the following:

    Your message did not reach some or all of the intended recipients.

    Subject: Testing
    Sent: 05/09/2007 11:31 AM

    The following recipient(s) cannot be reached:

    Bill S (bsxxxx@gxxxx.com) on 05/09/2007 11:31 AM
    503 valid RCPT command must precede DATA


    When I log into my webmail, I get the following:

    bsxxxx@gxxxx.com: no such user here.

    when in fact that user DOES exist.


    Sending email from the local server is the problem. this company receives emails from other people/companies without a problem. but once email is sent from the server that hosts the MX record (such as a website contact form), we have problems.

    thoughts?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    So, does the MX record point to their exchange server? If so, then you have to remove the domain from /etc/localdomains and put it in /etc/remotedomains (create the file as needed) exim will then use the MX record instead of trying to deliver locally.
     
  3. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    this worked great. thanks for pointing me in the right direction

    we've done this before with a couple other hosts, but no problems - unsure why this time it was a problem.... ??
     
Loading...

Share This Page