Exim ACL won't save, only the middle box?

Ashley-P

Member
Jun 4, 2006
10
0
151
Hi Everyone

This is a little odd, was checking my spam stats on the server today and noticed the only emails being rejected was all Verify sender rejections... so I checked my exim config to find it had reset to default, so I did my config out and start adding my rules again...but for some reason in the advanced exim editor I can't save any rules to the middle edit box below "begin acl" is this a new bug from an update or am I missing something stupidly obvious?

I'm sure I can manually edit the exim.conf via ssh but this isn't really what I want to keep doing, anyone else seen this error?

Cheers

Ash
 

Ashley-P

Member
Jun 4, 2006
10
0
151
good I'm not going mad then :)

As a temporary measure I've just replaced /etc/exim.conf & /etc/exim.conf.local with my backups and restarted exim and it's back to how it was... however as soon as you use the config editor to save anything in the middle acl box.... back to default


Just found this too..... http://bugzilla.cpanel.net/show_bug.cgi?id=4453
 
Last edited:

mctDarren

Well-Known Member
Jan 6, 2004
665
4
168
New Jersey
cPanel Access Level
Root Administrator
Above thread in a nutshell:

Check for corrupted /etc/exim.conf.local:

Code:
%¬LBLOCK%
should read:

Code:
%ACLBLOCK%
Edit that, then run /scripts/buildeximconf and then run service exim restart.

That seems NOT to fix the issue, however this procedure of editing exim.local.conf should take the place of editing the conf file through WHM until the bugzilla entry is addressed.

Editing just exim.conf can cause rebuild problems in the future, Chirpy recommends always using the above procedure.
 
Last edited by a moderator: