The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim and clamd service keeps of down

Discussion in 'E-mail Discussions' started by lldeepakll, Sep 21, 2012.

  1. lldeepakll

    lldeepakll Well-Known Member

    Joined:
    May 20, 2012
    Messages:
    86
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    I am facing problem on my server that is Exim and Clamd Service keeps on down (showing in service status). And after some time showing up. I have checked the exim panic log and get below result:

    2012-09-21 12:23:33 1TEx7F-0002uA-Cp failed to expand condition "${perl{enforce_mail_permissions}}" for enforce_mail_permissions router: Undefined subroutine &main::enforce_mail_permissions called.

    2012-09-21 12:23:33 1TEx7F-0002uA-Cp failed to expand condition "${perl{increment_max_emails_per_hour_if_needed}}" for increment_max_emails_per_hour_if_needed router: Undefined subroutine &main::increment_max_emails_per_hour_if_needed called.

    2012-09-21 12:23:34 1TEx7G-0002uY-Oy failed to expand condition "${perl{check_mail_permissions}}" for check_mail_permissions router: Undefined subroutine &main::check_mail_permissions called.

    2012-09-21 12:23:34 1TEx7G-0002uY-Oy failed to expand condition "${perl{enforce_mail_permissions}}" for enforce_mail_permissions router: Undefined subroutine &main::enforce_mail_permissions called.

    2012-09-21 12:23:34 1TEx7G-0002uY-Oy failed to expand condition "${perl{increment_max_emails_per_hour_if_needed}}" for increment_max_emails_per_hour_if_needed router: Undefined subroutine &main::increment_max_emails_per_hour_if_needed called.

    Please help me to solve this issue.

    Thanks.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Made any changes to EXIM recently? Not sure how helpful this is, but have you tried resetting EXIM?

    WHM > Service Configuration > Exim Configuration Manager, Reset tab.
     
  3. pwhjenny

    pwhjenny Well-Known Member

    Joined:
    Aug 31, 2012
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    You can try to run /scripts/buildeximconf script but make sure you take backup of your existing exim configuration file.
     
  4. lldeepakll

    lldeepakll Well-Known Member

    Joined:
    May 20, 2012
    Messages:
    86
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    I have checked the exim_mainlog and there are too many below logs showing. Below logs are showing only for a particular email id. Also this user or domain is not found in /etc/demodomains and /etc/demousers file. Permissions are also OK of this domain.


    2012-09-23 16:05:25 dovecot_login authenticator failed for localhost.localdomain (serverhostname) [127.0.0.1]:36274: 535 Incorrect authentication data (set_id=tarnpir@domain.com)
    2012-09-23 16:06:32 dovecot_login authenticator failed for localhost.localdomain (serverhostname) [127.0.0.1]:44893: 535 Incorrect authentication data (set_id=tarnpir@domain.com)
    2012-09-23 16:07:16 dovecot_login authenticator failed for localhost.localdomain (serverhostname) [127.0.0.1]:44897: 535 Incorrect authentication data (set_id=tarnpir@domain.com)
    2012-09-23 16:07:30 dovecot_login authenticator failed for localhost.localdomain (serverhostname) [127.0.0.1]:44900: 535 Incorrect authentication data (set_id=tarnpir@domain.com)
     
Loading...

Share This Page