exim and cpanel upgrade now exim permission issues

krnlpanic

Member
Dec 28, 2019
7
0
1
USA
cPanel Access Level
Root Administrator
Hello all.

I have a server that was a bit behind the times and I've spent two days upgrading cpanel, apache/PHP, mysql, exim, etc. I don't recall what my cpanel/WHM version was previously, but it was just upgraded to the most recent - 11.84.

During this process, I also updated exim to 4.92.3. My mail has worked for years up until this update, now I'm getting permission error such as the following:
  • Failed to create directory "/var/spool/exim/db": Permission denied
  • failed to open database lock file /var/spool/exim/db/retry.lockfile: Permission denied (euid=93 egid=93)
(uid/gid 93 is exim.exim)

/var/spool/exim and all directories below it are 750 mailnull.mail
drwxr-x--- 6 mailnull mail 4.0K Dec 28 16:16 exim
drwxr-x--- 2 mailnull mail 4.0K Sep 30 11:51 db
drwxr-x--- 32 mailnull mail 4.0K Dec 28 20:45 input
drwxr-x--- 32 mailnull mail 4.0K Dec 28 15:08 msglog
drwxr-x--- 2 mailnull mail 4.0K Dec 27 01:44 scan

It looks like exim is running as the exim user instead of mailnull, which is causing it to be unable to use the spool directories. I tried changing them recursively to exim.exim and restarting the server, but that didn't help.

I was hoping to find where I can change the exim runtime user to mailnull in /etc/exim.conf but can't find it.

What am I missing?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,418
1,000
313
cPanel Access Level
Root Administrator
Sorry to hear about these issues with Exim. On a test machine I just checked, where email is working normally under version 84, I have mailnull:mail for both /var/spool/exim and /var/spool/exim/db, so it seems your ownership and permissions are correct. It's possible there is another issue with the system but it may be best to get a ticket submitted to our team using the link in my signature so we can check this one out for you.