Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim and invalid Reply-To headers

Discussion in 'General Discussion' started by EdP, Jan 15, 2007.

  1. EdP

    EdP Member

    Joined:
    Dec 19, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Buckinghamshire, UK
    We receive occasional emails with invalid Reply-To headers. The exim log shows:

    Since the company sending these is so large that there is no realistic chance of getting to someone who can change things their end, I wondered if there is a way to allow emails with invalid Reply-To headers through - ideally in the WHM editor?

    Many thanks

    Ed
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    I doubt it as they're (or rather the client sending the email) breaking the SMTP RFC's.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. EdP

    EdP Member

    Joined:
    Dec 19, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Buckinghamshire, UK
    Thanks, I know that but am up against a brick wall getting anything changed their end. Our previous server used sendmail, which let these mails through.

    I read about a 'headers_checks_fail = false' entry in exim.conf that would seem to do what I want - but wondered if I could put it in the WHM Advanced Exim Editor instead - so it doesn't get overwritten (if this is indeed what I want)? If so, where do I put it?

    Best wishes, Ed
     
    #3 EdP, Jan 16, 2007
    Last edited: Jan 16, 2007
  4. EdP

    EdP Member

    Joined:
    Dec 19, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Buckinghamshire, UK
    I tried putting headers_checks_fail = false in several of the boxes of the Advanced Exim Editor, but get:

    'Configuration file has an invalid syntax. Please try again.'

    Can anyone point me at a place for Exim help so I can work out where, if anywhere, this needs to be put?

    Or would clearing the 'Verify the existence of email senders.' checkbox on the Simple Editor possibly do what I want?

    Any help much appreciated!

    Ed
     
  5. karlos

    karlos Member

    Joined:
    Oct 1, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    151
    same problem!! with same people!!

    five months later amadeus.net e-ticket aplication still have the same problem :confused:

    and for the solution they only have to send the email with something like

    right?

    well, I try to configure exim with headers_checks_fail = false :mad:
     
  6. EdP

    EdP Member

    Joined:
    Dec 19, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Buckinghamshire, UK
    Un-setting 'Verify the existence of email senders' in the Exim Configuration Editor allowed these emails through for me. I also pestered Amadeus (and still am, 6 months later!!) who have yet, as far as I am aware, to consider it serious enough to come up with a solution. Actually, I don't think they have a clue what I am talking about.

    Good luck, Ed:confused:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice