The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EXIM and sendmail configuration

Discussion in 'E-mail Discussions' started by SliderNMFD, Mar 31, 2005.

  1. SliderNMFD

    SliderNMFD Member

    Joined:
    Dec 6, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I've gone through some extensive reading and have yet to figure out what my issue really is. Basically, I can send email locally to any user on the server without problems. I am able to retrieve mail as any user as well via Outlook or any other mail program.

    I recently changed from a shared reseller environment to a standalone server. One of my clients uses some extensive php mail() scripts to do some mailings as well as receive comments and files for his sites. When the enduser tries to access the forum and submit, I get the following error in my exim_mainlog:

    Code:
    root@server1 [/var/log]# tail -f exim_mainlog
    2005-03-31 13:00:17 1DH4tt-0000CC-NC failed to expand condition "${perl{checkspam}}" for literal router: Gid 99 is not permitted to relay mail at /etc/exim.pl line 365.
    
    2005-03-31 13:00:17 1DH4tt-0000CC-NC ** me@gmail.com R=fail_remote_domains: unrouteable mail domain "gmail.com"
    2005-03-31 13:00:17 1DH4tt-0000CE-Og <= <> R=1DH4tt-0000CC-NC U=mailnull P=local S=1254
    2005-03-31 13:00:17 1DH4tt-0000CC-NC Completed
    2005-03-31 13:00:17 1DH4tt-0000CE-Og User 0 set for local_delivery transport is on the never_users list
    2005-03-31 13:00:17 1DH4tt-0000CE-Og == root@server1.server.com <nobody@server1.server.com> R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    2005-03-31 13:00:17 1DH4tt-0000CE-Og ** root@server1.server.com <nobody@server1.server.com>: retry timeout exceeded
    2005-03-31 13:00:17 1DH4tt-0000CE-Og root@server1.server.com <nobody@server1.server.com>: error ignored
    2005-03-31 13:00:17 1DH4tt-0000CE-Og Completed
    
    I'm lost as to what I need to change, but I need to have my client be able to send mail via the mail().

    The sendmail path is correct in my php.ini file as well.

    Any help would be appreciated.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make sure that you have WHM > Change System Mail Preferences > nobody's mail > set to a valid email address.
     
  3. SliderNMFD

    SliderNMFD Member

    Joined:
    Dec 6, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I updated that to send it to my main account on there and still a no go. Here is where I am at right now after updating my script a little bit:

    Code:
    2005-03-31 15:20:25 1DH75V-0001uh-AT failed to expand condition "${perl{checkspam}}" for lookuphost router: Gid 99 is not permitted to relay mail at /etc/exim.pl line 365.
    
    2005-03-31 15:20:25 1DH75V-0001uh-AT failed to expand condition "${perl{checkspam}}" for literal router: Gid 99 is not permitted to relay mail at /etc/exim.pl line 365.
    
    2005-03-31 15:20:25 1DH75V-0001uh-AT ** me@gmail.com R=fail_remote_domains: unrouteable mail domain "gmail.com"
    2005-03-31 15:20:25 1DH75V-0001uj-Bo <= <> R=1DH75V-0001uh-AT U=mailnull P=local S=1252
    2005-03-31 15:20:25 1DH75V-0001uh-AT Completed
    2005-03-31 15:20:25 1DH75V-0001un-DT <= <> U=me P=local-bsmtp S=1618 id=E1DH75V-0001uj-Bo@server1.server.com
    2005-03-31 15:20:25 1DH75V-0001un-DT => slidernmfd <slidernmfd@myurl.com> R=virtual_user T=virtual_userdelivery
    2005-03-31 15:20:25 1DH75V-0001un-DT Completed
    2005-03-31 15:20:25 1DH75V-0001uj-Bo => slidernmfd <slidernmfd@myurl.com> R=virtual_sa_user T=virtual_sa_userdelivery
    2005-03-31 15:20:25 1DH75V-0001uj-Bo Completed
    
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    What version of exim and cPanel are you running?
     
  5. SliderNMFD

    SliderNMFD Member

    Joined:
    Dec 6, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    When I turned off the following:

    Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required)

    it would send emails without a problem.

    WHM 10.0.0 cPanel 10.0.0-R112
    exim-4.44-0_cpanel_smtpctl_av_rewrite_mm2_mmmtrap_exiscan_md5pass

    The problem is from what I read, that option from the Tweek Settings cuts down on spam and that's a good thing because it adds a second layer of authentication to emails.
     
Loading...

Share This Page