The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim and Spamd Restart Issue

Discussion in 'E-mail Discussions' started by cyclone, Apr 19, 2007.

  1. cyclone

    cyclone Active Member

    Joined:
    Jul 15, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I try to restart exim, and I get the below:

    root@server1 [/etc/init.d]# service exim restart
    Shutting down clamd: [ OK ]
    Shutting down exim: [ OK ]
    Shutting down antirelayd: [ OK ]
    Shutting down spamd: [ OK ]
    Starting clamd: [ OK ]
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]


    For some reason it is shutting down spamd, but will not start spamd. So, I get an email after this saying that spamd has failed to start and is restarting automatically. Anyway to fix this problem?

    Thanks,
    Dennis
     
  2. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    spamd does not need to start if you have it turned off in cpanel settings. You will need to turn off spamd especially if you are using mailscanner or assp. Mailscanner will run spamd manually from within itself and assp does not need spamassassin.
     
  3. cyclone

    cyclone Active Member

    Joined:
    Jul 15, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I don't have assp or mailscanner installed on the server. So, I need spamd to startup lol
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    ls -l /etc/spam*, check tweaksettings, check service manager
     
  5. cyclone

    cyclone Active Member

    Joined:
    Jul 15, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Service manager has enable and monitor checked off.

    And in doing that code you recommended, I got the following:

    root@server1 [~]# ls -l /etc/spam*
    -rw-r--r-- 1 root root 0 Apr 16 09:39 /etc/spamdisable
    -rw-r--r-- 1 root root 0 Aug 16 2005 /etc/spammers
     
  6. Sabaote

    Sabaote Well-Known Member

    Joined:
    Dec 19, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ribeirao Preto, Brazil
    Hi..


    You just need to delete the file:
    /etc/spamdisable

    And restart exim, Spamd will be restarted as well..

    []'s
     
Loading...

Share This Page