The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Basic Editor Smarthost Support Questions

Discussion in 'E-mail Discussions' started by vaxhax, Nov 3, 2016.

Tags:
  1. vaxhax

    vaxhax Member

    Joined:
    Nov 3, 2016
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Hey folks,

    I have a postfix server on the same internal network as my WHM server. IN THE END, I just want to route every single outgoing mail through the postfix server.
    -----

    The only threads I've found about configuring a Smarthost all add routers and transport sections in the Advanced Editor, but I am hoping to avoid that if possible. So:

    In the Exim Basic Editor there is a control to enable Smarthost Support! I put my mail server internal IP address there and the Exim service restarts. Excellent, until I send a mail from the command line.

    Suddenly, the mail is frozen in the queue and won't route for any destination giving the short error:

    name@domain.com is undeliverable: The mail server could not deliver mail to mail@domain.com. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.

    ---

    The exim debug output gives quite a lot of info, but to narrow it down the main issue is that every lookup for domain.com fails in each of the router sections.

    So it seems the one (Basic Editor) setting is insufficient to route the email. Were all these router sections being checked when Exim thought localhost was the MTA?

    What else needs to be done after setting the smarthost IP address in Basic to make it work exactly as it did before? I don't need to do any special domain restriction at this time, just shove everything into postfix.

    Thank you very much,
    Chris
     
  2. vaxhax

    vaxhax Member

    Joined:
    Nov 3, 2016
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Every time I try to edit that post it won't let me save due to the filter thinking my posting something spamlike, therefore I will reply.

    The documentation doesn't seem to indicate anything else is necessary. I'm running 60 (build 15)
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @vaxhax,

    Could you verify if the "WHM >> Security Center >> SMTP Restrictions" option is enabled on this system? It's documented at:

    SMTP Restrictions - Documentation - cPanel Documentation

    If so, try disabling it and let us know if the issue persists. Also, if you use CSF, review the "SMTP_BLOCK" setting.

    Thank you.
     
  4. vaxhax

    vaxhax Member

    Joined:
    Nov 3, 2016
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Thanks @cPanelMichael . I did have it enabled, I disabled it. I am not running CSF. After disabling SMTP Restrictions I re-enabled Smarthost via IP.

    Attempting to send mail gives the same errors in /var/log/exim_main. What's next? This is a fresh install on a fresh Centos 7.2

    Based on those docs, it wouldn't matter anyway (SMTP Restrictions) since I am sending the mail as root.

    Thank you,
    Chris
     
    #4 vaxhax, Nov 3, 2016
    Last edited: Nov 3, 2016
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page