The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim blocking Gmail email

Discussion in 'E-mail Discussions' started by hamper, Sep 22, 2006.

  1. hamper

    hamper Well-Known Member

    Joined:
    Apr 28, 2006
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Does anyone know of a fix to allow Gmail & Hotmail emails to stop being blocked by the email server?

    any help is appreciated,

    thanks

    hamper
     
  2. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Post the errors you get in the logs.
     
  3. hamper

    hamper Well-Known Member

    Joined:
    Apr 28, 2006
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    there isn't anything in the log that I can see. this is what I'm getting back (well bounced) back to me in email.

    where all should I be looking in the logs?
     
  4. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Ok, look in the mail queue and try to deliver one and then post back what it says then.
     
  5. hamper

    hamper Well-Known Member

    Joined:
    Apr 28, 2006
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    thanks,

    I tried and nothing shows in the mail queue. this is one reason I'm confused.
     
  6. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Ok, in tweak settings uncheck the box

    "Track the origin of messages sent though the mail server by adding the X-Source headers (exim 4.34+ required)"

    Also uncheck boxtrapper spam trap

    and see if that works for ya.

    also check /var/log/exim_paniclog
     
  7. hamper

    hamper Well-Known Member

    Joined:
    Apr 28, 2006
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    hmm ok, this part was checked

    I checked the logs and it was saying "nobody" wasn't allowed to send email so it was stopping it. So, I unchecked that box above and tried to send an email and only one part still came through, but these are emails others are sending also, so i'm going to wait a few and see what happens if they stop or not. If they dont stop then I know it didn't fix it and I'll uncheck box trapper because it was checked but the other wasn't you mentioned.

    anything else perhaps? thanks
     
  8. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Ok I figured the "nobody" box was not checked because you mentioned no error messages earlier.

    It sounds like you are all set then. Have you tried sending an email via root?
    in ssh try something like

    tail /var/log/messages | mail -s "testmail" user@gmail.com
     
  9. hamper

    hamper Well-Known Member

    Joined:
    Apr 28, 2006
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    yes, thank you very much. everything seems to be working great now.
     
  10. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    Hi,
    I am facing the same issue. Gmail forwards are being blocked.

    I ran the following:

    Code:
    /scripts/updatenow
    /scripts/rpmup
    /scripts/eximup --force
    
    Then I did "Deliver Now" again. Here's the messages I got:

    Code:
    LOG: MAIN
      cwd=/usr/local/cpanel/whostmgr/docroot 4 args: exim -v -M 1QHc0p-0006ZX-DG
    delivering 1QHc0p-0006ZX-DG
    LOG: MAIN
      => discarded  R=has_alias_but_no_mailbox_discarded_to_prevent_loop
    Connecting to gmail-smtp-in.l.google.com [74.125.159.27]:25 ... failed: Connection timed out (timeout=5m)
    LOG: MAIN
      gmail-smtp-in.l.google.com [74.125.159.27] Connection timed out
    Connecting to alt1.gmail-smtp-in.l.google.com [74.125.115.27]:25 ... failed: Connection timed out (timeout=5m)
    LOG: MAIN
      alt1.gmail-smtp-in.l.google.com [74.125.115.27] Connection timed out
    Connecting to alt2.gmail-smtp-in.l.google.com [209.85.227.27]:25 ... failed: Connection timed out (timeout=5m)
    LOG: MAIN
      alt2.gmail-smtp-in.l.google.com [209.85.227.27] Connection timed out
    

    Any ideas on why? I have disabled the usual WHM "smtp tweak" stuff, as recommended in CSF documentation.

    Thanks
     
  11. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please specify what specific options have been disabled per those recommendations by CSF.

    Next, can you post the contents of your resolver file?

    Code:
    cat /etc/resolv.conf
    You might try adding the Google public resolvers to it:

    Code:
    nameserver 8.8.4.4
    nameserver 8.8.8.8
    If your resolver isn't able to properly resolve gmail addresses, it would cause a connection timeout when trying to send to gmail addresses.

    You can also test the email you are trying to send to for the routing results with this command:

    Code:
    exim -bt user@gmail.com
    Please replace user@gmail.com with the gmail account.
     
  12. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    387
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Hi,

    I have had the same problem on one of our Cloud server. The reason was CSF was crashed due to some reason and it was blocking the SMTP connections. I had reinstalled CSF to fix this.

    Thank you,
     
Loading...

Share This Page