Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
Hi,

We've setup Exim (for security reasons) to only bounce e-mail headers (and not the full e-mail) in case of an incorrect recipient's e-mail address, by adding the following to the Exim configuration:

Code:
bounce_return_message = false
bounce_return_body = false
This works without problems.

We'd also like to setup a message to let the receiver know about this and have found the following in another server's setup bounce :

X-Exim-DSN-Information: Due to administrative limits only headers are returned
The question: How can the latter be added to our bounces?

Thanks.
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
@cPanelMichael:

That thread is focussed on autoresponders, while mine is focussed on a bounce message someone receives when an e-mail address is not valid.

Hereby a sample of such an e-mail:

This message was created automatically by mail delivery software.


A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:


[email protected]
(ultimately generated from [email protected])
host mx4.email.ext [111.222.333.444]
SMTP error from remote mail server after RCPT TO:<[email protected]>:
552 5.2.2 quota exceeded


Reporting-MTA: dns; server.domain.ext


Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0
Remote-MTA: dns; mx4.email.ext
Diagnostic-Code: smtp; 552 5.2.2 quota exceeded


Return-path: <[email protected]>
Received: from sub.dynamic.provder.ext ([222.333.444.555]:49244 helo=pc.domain.ext)
by server.domain.ext with esmtpsa (TLSv1:DHE-RSA-AES256-SHA:256)
(Exim 4.89_1)
(envelope-from <[email protected]>)
id 1eU5Tb-0007oI-Ib
for [email protected]; Wed, 27 Dec 2017 07:46:08 +0100
X-Priority: 2 (High)
Date: Wed, 27 Dec 2017 07:46:07 +0100
To: "A.N. Onymous" <[email protected]>
From: "Some.one - Abuse Dept." <[email protected]>
Subject: Fwd: lfd on server.domain.ext: Suspicious process running under
user someuser
Mime-Version: 1.0
Content-Type: multipart/alternative;
boundary="=====================_379737==.ALT"
X-Exim-DSN-Information: Due to administrative limits only headers are returned
I'd like to have the last line added to our bounces as well. How do I do this?

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

The thread originates with a question about autoresponders, but then goes into information about Delivery Status Notifications with Exim (DSN), which is what you need to enable to include that information in the bounce message.

Thank you.
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
@cPanelMichael

So, if I understand correctly, I've to add the following line :

Code:
dsn_advertise_hosts = *
to the file /etc/exim.conf.local under the @config@ section in order to have the header :

X-Exim-DSN-Information: Due to administrative limits only headers are returned
added to our bounces?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

You'd need to enable DSN first before you could include DSN information in the message headers, so the instructions in that thread are the the first step to take. Additionally, I suggest reviewing the Exim documentation for more information about "dsn_advertise_hosts" at:

14. Main configuration

That said, as far as including that information in the message header, I don't believe that happens automatically. Note that this is a custom Exim configuration, so it's not something we offer support for. You may want to consult with the Exim user's mailing list or a system administrator for help customizing Exim to include that in the header:

Exim-users Info Page
System Administration Services | cPanel Forums

Thank you.