The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim; can send... sometimes.

Discussion in 'General Discussion' started by Blasted_Heath, Apr 5, 2005.

  1. Blasted_Heath

    Blasted_Heath Member

    Joined:
    Dec 19, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    When connecting to the mailserver and sending, email is received fine, and there is no problem in receiving email either.

    However, when an email is sent from php, or any other script, including webmail, it fails, and doesn't get delivered, giving the vague response of "unrouteable mail domain "gmail.com"" (etc).

    There was earlier an accident which caused /usr/sbin/sendmail to be removed from the server, but it was put back on and the correct permissions set on it. Upon restarting exim it says the following:
    Anyone have any ideas on fixing?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    When you say that /usr/sbin/sendmail was put back, are you usre it was done correctly? One way to be sure is to remove it again and run:

    /scripts/exim4 --latest

    If it is OK, do you have a valid email address in all of the fields in WHM > Change System Mail Preferences (esp. nobody's email)? Also, do you have WHM > Tweak Settings > Prevent the user 'nobody' from sending out mail to remote addresses > checked? It should not be.
     
  3. Blasted_Heath

    Blasted_Heath Member

    Joined:
    Dec 19, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply, I've managed to fix it now, after checking the exim paniclog, I realised that spamassasin had started stopping all mail, and simply restarting spamasassin cured that. It all seems to be working now :)
     
  4. vishwas

    vishwas Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Front of PC
    I have same issue , and I checked that the 'nobody' is checked in WHM but i dont want to uncheck that is there any other vay to resovle this issue.

    Other all test i did

    exim -bt ; exim -bt -d ; dig and everything shows correct

    any suggetion will appreciable.
     
Loading...

Share This Page