The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Causing 100% CPU Usage

Discussion in 'E-mail Discussions' started by pr0gr4mm3r, Dec 11, 2007.

  1. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    After searching the forums, I was unable to find a solution to my problem. Exim is causing my server to be at constant 100% usage. My load average isn't extreme, it's at 1.5-2 (AMD 1.8GHz). I realized the issue this morning when I got an automated email stating that my server was at 100% load for over six hours.

    The dictionary attack is enabled, :fail: is used by default, and I see no evidence of spamming (queue is nearly empty and delivery rate is normal).

    My Exim log file just shows the junk mail being rejected, and this warning:

    Code:
    2007-12-11 10:44:25 H=(ppp91-77-5-103.pppoe.mtu-net.ru) [91.77.5.103] Warning: ACL "warn" statement skipped: condition test deferred: ratelimit database not available
    2007-12-11 10:44:31 Failed to get write lock for /var/spool/exim/db/ratelimit.lockfile: timed out
    
    Can someone please help me find a solution?
     
  2. markfrompf

    markfrompf Well-Known Member

    Joined:
    Mar 27, 2006
    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Los Angeles, CA
    I also had the issue of Exim using up 100% CPU.

    It was fixed by running ./fixeverything

    Keep in mind there are a lot of problems with the fix everything script so use at your expense. Also, I don't recall getting the error message you posted.
     
  3. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    What kind of problems? I did run it, and it said that I had to log out and log back in 30 minutes later, so I will see if it worked then.
     
  4. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    The script is done, and my load is still ~1.80 with exim being 98% of it.
     
  5. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Well, I did get the load to stop, but I had to disable some options in the Exim configuration:

    RBL: bl.spamcop.net [?]
    RBL: zen.spamhaus.org [?]
    Add sender rates to the mail log [?]

    I would really like to have the RBLs enabled as they take a load off of spamd.
     
Loading...

Share This Page