The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Clogging

Discussion in 'General Discussion' started by robster69, Feb 10, 2006.

  1. robster69

    robster69 Member

    Joined:
    Jan 17, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I have a VPS dedicated for a client who sends thousands of legitimate notifications at regular intervals. Many go to the same receiving server. The problem seems to lie with Exims method of delivery with a single remote server.

    I tail the log when Exim makes it's run, and also have spoken with the Sys Admin of the receiving server during the run. We notice that Exim opens a new connection for each message, instead of using that open connection to dump as many emails as possible. The multiple connections then shut down the receiving server (they have it set to limit connections/hour per sender), which results in a "retry time not reached for any host". Getting 5000 emails through by this method will take several days!

    Right now, my queue is out of control with legitimate email. By the way, each email is unique so it's not something that can be sent "bulk" using bcc or cc.

    Is there something I am missing here? Surely Exim is more efficient than this. Perhaps there is a setting I can alter, like remote_max_parallel or max_rcpts ? Does anybody have any experience with this issue or solving it?

    Thanks in advance.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It should do. According to the exim specs:
    http://www.exim.org/exim-html-4.50/doc/html/spec_44.html
    If that isn't happening, then there could be a problem with the hints database. On a cPanel server this would be /var/spool/exim/db/misc by my reading:
    http://www.exim.org/exim-html-4.50/doc/html/spec_49.html#SECT49.11
     
  3. robster69

    robster69 Member

    Joined:
    Jan 17, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply. Yep, we are literally on the same page in the Exim documentation. You may have hit on the problem. I can't seem to read the hints misc db.

    Supposedly max_rcpts default is 100. Trying to set it in the 'Exim Configuration Editor' results in an error. While setting remote_max_parallel > 1 had no noticeable result, even after Exim restarted from command line (per your advice on other threads).

    Will continue to play with this. If any other ideas/experiences, let me know.

    Thanks
     
Loading...

Share This Page