The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim.conf Spam Header Rewriter Error?

Discussion in 'E-mail Discussions' started by lkraven, Jun 21, 2007.

  1. lkraven

    lkraven Member

    Joined:
    Jun 19, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Recently, I noticed all my spam emails in the spam box had gone from being titled:

    *** SPAM *** (Actual Subject)

    To just

    *** SPAM ***

    On further investigation, it appears as though the latest version of WHM/CPanel is using this line in the exim.conf file:

    add_header = X-Spam-Subject: ***SPAM*** $h_subject*

    The last asterisk appears to be an error. It should instead be:

    add_header = X-Spam-Subject: ***SPAM*** $h_subject:

    Anyone else getting this? I can fix it using the advanced editor, but it appears as though the default editor is writing this incorrectly.
     
  2. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I am also seeing this problem, I'm using cPanel 11.4.19-RELEASE_14379.

    Your suggestion ($h_subject* to $h_subject:) did resolve this. Thanks for posting this.
     
    #2 sparek-3, Jun 26, 2007
    Last edited: Jun 26, 2007
  3. checking

    checking Registered

    Joined:
    Apr 30, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    After a whole day of trying to track down what happened to the subject in the header, this post solved my problem.

    add_header = X-Spam-Subject: ***SPAM*** $h_subject

    No * at the end of it - bah, typos can suck.
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    This has been corrected in: WHM 11.1.0 cPanel 11.4.19-R14379
     
Loading...

Share This Page