The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim config error - upgrading from 6.8 to 7.0

Discussion in 'E-mail Discussions' started by schris403, Jun 3, 2010.

  1. schris403

    schris403 Registered

    Joined:
    Jun 3, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I can't seem to upgrade or reset my exim configuration to defaults after the recent 6.8 to 7.0 upgrade that was applied. I am using version 11.25.0-STABLE_46156. I am getting the following e-mail:

    cPanel was unable to automatically merge your Exim configuration with the new settings that shipped
    with the build you have installed (11.25.0-STABLE_46156) because you have a custom ACL configuration
    which cannot be automatically configured.

    To avoid any mail downtime, we thought it was best to leave
    your previous configuration intact until the new configuration can be properly installed. In order to
    complete this configuration update, you will need to manually merge your configuration with the new
    configuration settings. Please follow the steps below to complete this update:

    1. Enter WHM at /https://mydomain.com:2087/
    2. Enter the Exim Configuration Editor:
    (Service Configuration >> Exim Configuration Editor >> Advanced Configuration Editor)
    3. Notate any custom changes you have made in the ACL section.
    You may also which to make a copy of /etc/exim.conf.local
    and /etc/exim.conf.localopts as custom settings are contained in these files.
    4. Click the 'Reset ACL Config to Defaults' button.
    5. Reinstall your advanced custom settings.


    Note: Until you manually complete this update, automatic spam filtering may have been rendered inoperable to
    prevent any mail loss. (This generally only applied is you were upgrading from cPanel 10.x)

    Current Config Version: 6.800000
    New Config Version: 7.000000


    When I try to reset exim to defaults like it suggests, I get this:
    Your Exim ACL configuration has been reset to the defaults.

    Configuration file has an invalid syntax. Please try again.

    Enabled system filter options: attachments|fail_spam_score_over_200|spam_rewrite
    Enabled ACL options in block ACL_POST_SPAM_SCAN_CHECK_BLOCK: mailproviders
    Enabled ACL options in block ACL_RBL_BLOCK:
    Enabled ACL options in block ACL_PRE_RECP_VERIFY_BLOCK: dictionary_attack
    Enabled ACL options in block ACL_MAILAUTH_BLOCK:
    Enabled ACL options in block ACL_RCPT_SOFT_LIMIT_BLOCK:
    Enabled ACL options in block ACL_TRUSTEDLIST_BLOCK:
    Enabled ACL options in block ACL_MAIL_BLOCK: requirehelo|requirehelonoforge|requirehelosyntax
    Enabled ACL options in block ACL_RATELIMIT_SPAM_BLOCK: ratelimit_spam_score_over_200
    Enabled ACL options in block ACL_RATELIMIT_BLOCK: 0tracksenders
    Enabled ACL options in block ACL_NOTQUIT_BLOCK: ratelimit
    Enabled ACL options in block ACL_CONNECT_BLOCK: ratelimit|spammerlist
    Enabled ACL options in block ACL_RCPT_HARD_LIMIT_BLOCK:
    Enabled ACL options in block ACL_SPAM_BLOCK: deny_spam_score_over_200
    Detected spam handling in acls, disabling spamassassin in routers & transports!.
    SpamAssassin method remains unchanged
    Configured options list is:
    Provided options list is: hostlist senderverifybypass_hosts|hostlist skipsmtpcheck_hosts|hostlist spammeripblocks|hostlist backupmx_hosts|hostlist trustedmailhosts|domainlist user_domains|smtp_receive_timeout|ignore_bounce_errors_after|timeout_frozen_after|auto_thaw|callout_domain_negative_expire|callout_negative_expire|daemon_smtp_ports|tls_on_connect_ports|tls_require_ciphers|acl_smtp_connect|acl_smtp_mail|acl_smtp_notquit|spamd_address
    Exim Insert Regex is: virtual_userdelivery|virtual_aliases|lookuphost|virtual_user|address_pipe|virtual_sa_user|localuser
    Exim Replace Regex is: virtual_sa_user|sa_localuser|virtual_sa_userdelivery|local_sa_delivery|central_filter|central_user_filter|democheck|fail_remote_domains|fixed_login|fixed_plain|has_alias_but_no_mailbox_discarded_to_prevent_loop|literal|local_delivery|local_delivery_spam|localuser|localuser_spam|lookuphost|remote_smtp|userforward|virtual_aliases|virtual_aliases_nostar|virtual_user|virtual_user_spam|virtual_userdelivery|virtual_userdelivery_spam
    Exim Match Insert Regex is: quota_directory|maildir_format
    Skipping lookuphost insert as it requires boxtrapper and it is disabled or unavailable.
    Skipping virtual_user insert as it requires boxtrapper and it is disabled or unavailable.
    Skipping localuser insert as it requires boxtrapper and it is disabled or unavailable.
    Skipping virtual_userdelivery insert as it requires boxtrapper and it is disabled or unavailable.
    Exim version 4.69 #1 built 16-Mar-2009 15:18:11
    Copyright (c) University of Cambridge 2006
    Berkeley DB: Sleepycat Software: Berkeley DB 4.3.29: (January 7, 2007)
    Support for: crypteq iconv() IPv6 PAM Perl OpenSSL Content_Scanning Old_Demime Experimental_SPF Experimental_SRS Experimental_DomainKeys Experimental_DKIM
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz passwd
    Authenticators: cram_md5 dovecot plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile/maildir autoreply pipe smtp
    Size of off_t: 8


    Error message from syntax check:
    2010-06-03 06:54:01 Exim configuration error in line 1277 of /etc/exim.conf.buildtest.work.1on4ahJXmPPQdlsM:
    unknown or malformed retry error "="


    Please let me know if you have any suggestions.

    Thanks!
    Chris
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Can you post that line, including the few lines before and after it?

    Thank you.
     
  3. schris403

    schris403 Registered

    Joined:
    Jun 3, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Actually that file seems to be a temporary file during the process as it is not there when I manually look for it..

    Chris
     
  4. olivechicago

    olivechicago Registered

    Joined:
    Mar 2, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Anything ever come of this? I'm having a similar issue

    2011-03-02 16:42:42 Exim configuration error in line 264 of /etc/exim.conf.buildtest.work.zAF6PacFpNEQHQ9F:
    missing or malformed ACL name

    exim.conf.buildtest.work.RanD0MChaRat3rs is indeed a temp file.

    264 in exim.conf is commented out ##DO NOT EDIT THIS BLOCK or something to that effect.
     
Loading...

Share This Page