The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Config Issues

Discussion in 'E-mail Discussions' started by etono, Oct 13, 2007.

  1. etono

    etono Member

    Joined:
    Jun 20, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to reduce the amount of spam messages. I changed all clients from :blackhole: to :fail: and also setup Chirpy's dictionary attack. In the advanced exim editor just delow the dictionary part I added the following:

    Code:
    deny message = HELO/EHLO does not specify a domain or IP
        log_message = HELO/EHLO has no dot
        condition = ${if match{$sender_helo_name}{\\.}{no}{yes}}
    
    I was led to believe that this would affect the mail coming in, however it also seems to affect clients that are using Outlook, as one such client received the HELO/EHLO does not specify a domain or IP error message. I checked out the header of a previous email he had sent me and sure enough the HELO is set to his name rather than IP or domain name. Sending from squirrel mail it set the helo to his domain name correctly, so the email goes through. Is there a way to have him set the helo message correctly on his outlook.
     
  2. Bima

    Bima Member

    Joined:
    Jan 2, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    You may consider excluding authenticated SMTP sessions from that ACL directive by adding this:

    !authenticated = *

    Then ask your users to make sure that they have SMTP Authentication enabled in their e-mail clients.

    Marek
     
  3. etono

    etono Member

    Joined:
    Jun 20, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for the suggestion Marek. They are using SMTP authentication in their email client. Should I add that line just above the condition like this:

    Code:
    deny message = HELO/EHLO does not specify a domain or IP
        log_message = HELO/EHLO has no dot
        !authenticated = *
        condition = ${if match{$sender_helo_name}{\\.}{no}{yes}}
    
     
  4. etono

    etono Member

    Joined:
    Jun 20, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Put it after the condition. Works like a charm. Thank You!
     
  5. tprice42

    tprice42 Active Member

    Joined:
    Sep 10, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    You might also want to put this in there too:

    !hosts = +relay_hosts

    This will allow for any host IP addresses that you have in /etc/alwaysrelay and those that are automatically added by antirelayd (pop before smtp)
    This will have the added benefit of not requiring authenticated smtp.

    Just as an aside i also use fake MX records and greylisting to reduce spam even more, i'm currently sitting on about %5 real mail to spam ratio. I can explain more if anyone's interested.
     
    #5 tprice42, Oct 14, 2007
    Last edited: Oct 14, 2007
  6. etono

    etono Member

    Joined:
    Jun 20, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thank you tprice42. I am interested in the greylisting technique you mentioned and would love to learn more about it.
     
  7. tprice42

    tprice42 Active Member

    Joined:
    Sep 10, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
Loading...

Share This Page