The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim configuration error

Discussion in 'General Discussion' started by ckh, Feb 11, 2004.

  1. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    I'm running FreeBSD 4.9 and have exim 4.24.

    For quite some time I've been getting a permission error and a syntax error when every I use the exim configuration editor in either simple or advanced mode.

    I get the following

    -C Permission denied
    Exim version 4.24 #4 built 10-Dec-2003 16:57:18
    Copyright (c) University of Cambridge 2003
    Probably Berkeley DB version 1.8x (native mode)
    Support for: iconv() IPv6 PAM Perl OpenSSL
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile/maildir/mailstore/mbx autoreply lmtp pipe smtp
    Fixed never_users: 0
    Contains exiscan-acl patch revision 13 (c) Tom Kistner [http://duncanthrax.net/exiscan/]
    Configuration file has an invalid syntax. Please try again.
    /etc/exim.conf -> /usr/local/etc/exim/configure

    I noticed that on my other freebsd server that exim 4.30 was updated but for some reason it wasn't updated on the machine with the error message.

    Mail works properly but it just doesn't seem to upgrade.

    Any clues as to where I can look?

    CKH
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    I can't help much, but have you tried
    chown root /etc/exim.conf ?

    How about
    mv /etc/exim.conf /etc/exim.conf.bak

    and then uploading your exim.conf file from the server that works?
     
  3. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    Yep, tried the exim.conf and also tried the /usr/local/etc/exim/configure file also from the other server, didn't have any effect. Still get that darn error.

    Checked the ownership of the exim.conf file and it matched the other server.

    It's gotta be something else, but, I have no idea what. Also checked the flags to make sure the schg flag was set.

    Thanks for trying though..

    CKH
     
  4. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Good luck. I'd try submitting a ticket to cpanel.
     
  5. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    Same here for a server with RH 9
     
Loading...

Share This Page