The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Configurator Tweak

Discussion in 'General Discussion' started by secureID, Jun 24, 2004.

  1. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    I want to purge all mail pending in the main queue and have applied the following tweaks in Exim Configurator:

    ignore_bounce_errors_after = 1d
    timeout_frozen_after = 1d

    Can anyone tell me why these do not work.
     
  2. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Does anyone know how to configure Exim to automatically purge mail the remains in the main mail queue undelivered?
     
  3. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    How about this ... would anyone know of the server file name of the exim mail mail queue? I will just clear it using cron.
     
  4. kwimberl

    kwimberl Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    Look in here:

    /var/spool/exim/input
    /var/spool/exim/msglog
     
  5. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    go to the last two fields in the advanced exim.conf editor in WHM and enter your queue values. Exim will then automatically take care of it.
     
  6. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    cyberspirit-

    Thanks for the tip. I moved the following 2 lines from the very first textbox (where I had them) in the advanced mode of exim config to the very last textbox:

    ignore_bounce_errors_after = 1d
    timeout_frozen_after = 1d

    When I did that I got an configuration error. Can you tell me exactly where to put these commands. Thanks :)
     
  7. cyberspirit

    cyberspirit BANNED

    Joined:
    Jun 27, 2003
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    0
    well, I never said that you should enter "your" text into these fields, I talked about queue time out values.
    Go to the last to fields in WHM exim conf editor and see the example and enter something accordingly.
    I also highly recommend the documentation at exim.org if you are not familiar with Exim.
    The values you are trying to use - just forget about them, they are not needed for what you are trying to accomplish.
     
  8. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Has anyone successfully achieved this yet?
     
  9. dianaward

    dianaward Well-Known Member

    Joined:
    Dec 9, 2002
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Twitter:
    On my servers with heavy mailers,

    (I host quite a few autoresponder service scripts) I put:

    * refused F,2h,15m; G,16h,1h,1.5; F,36h,8h
    * * F,2h,15m; G,16h,1h,1.5; F,1d,8h

    in the last box of the exim configuration editor. This was recommended a year or so ago by someone at this forum, and it works pretty well for me, although I confess I don't know all that much about exim or whether this is "best practice" or not.
     
  10. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Wow, thanks 'dianaward'...I didn't think there was a solution to this anomaly with Exim. Every morning I manually purge the queue which gets up over 1000 messages a day. Somewhere in the Exim or cPanel or WHM system there is a bug but to-date, noone has been able to help me with it.

    I will try your suggestion...hopefully I can get out of the manual-purge-task and use a little automation ;)
     
  11. secureID

    secureID Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Thanks again Diana but that did not do it...my queue still fills up and the only way to get rid of the nasty deadmail messages is to purge the queue manually. Hopefully Exim, or cPanel, or WHM will fix the bug in the future. :(
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    AFAIK, there aren't any bugs. Are you sure that:

    1. Tried resetting exim.conf back to defaults:

    /scripts/reseteximtodefaults

    2. You have no sites overquota (that will cause mail queue buildup unless you disable queuing of over quota accounts)

    3. You've replaced any :blackhole: or /dev/null aliases in /var/aliases and made them :fail:
    http://www.configserver.com/free/fail.html

    4. Installed a dictionary attack ACL:
    http://www.configserver.com/free/eximdeny.html

    5. Checked the email to find out what it is and why it is queuing in the first place?

    6. Checked that your DNS resolvers work

    7. Checked that users haven't forwarded email to accounts that are full/non-existent
     
  13. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Hmmm . . . I think I have all of those steps covered except #2. (I have Chirpy handle this stuff for me, so it is always up-to-date :D )

    It appears that the queue isn't purging 8-9 day old queued mail (addressed to remote user whose server isn't accepting connection), when there is 1 day old queued mail addressed to a local user whose disk usage is at his quota.

    Does this mean that the purging process won't run when any local/over quota messages are queued, even if the messages to be purged are not local?

    Thanks,
    Bill
     
  14. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  15. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Thanks. I did that, but I notice that the same variables are set lower in the exim config file ... does a later variable setting rule, or does the first?
     
  16. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Does it? Ah. Well it wouldn't help then. The first one take precedence.
     
Loading...

Share This Page