The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim constant restart

Discussion in 'E-mail Discussions' started by Gavo, Jul 31, 2016.

  1. Gavo

    Gavo Member

    Joined:
    Nov 8, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I am using EasyApache 4 & couldn't get perl imagick to install/work, So I updated from Release to Current to see if the problem was fixed (It wasn't so I re-wrote my script to use GD)

    Since updating Exim keeps restarting & I don't know how to fix it, I tried force re-install.

    i.imgur.com/9EYJVao.png


    When I 1st updated to EasyApache 4 I tried to downgrade to 3 but httpd service wasn't installed so I reverted back to 4, I now have sites that depend on older php versions so would like to keep 4 anyway.

    How can I fix this?

    Thanks
     
    #1 Gavo, Jul 31, 2016
    Last edited by a moderator: Jul 31, 2016
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,146
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello :),

    Have you tried to update cPanel forcefully on your server ? I can see there is an issues with the perl modules.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,785
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Please post the output from the following commands:

    Code:
    perl -v
    ls -al /usr/bin/perl /usr/local/bin/perl
    ls -al /usr/local/cpanel/3rdparty/bin/perl
    /scripts/check_cpanel_rpms --fix
    Thank you.
     
  4. Gavo

    Gavo Member

    Joined:
    Nov 8, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I tried to force update as posted above.


    Code:
    [root@srv ~]# perl -v
    
    This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux-thread-multi
    (with 29 registered patches, see perl -V for more detail)
    
    Copyright 1987-2012, Larry Wall
    
    Perl may be copied only under the terms of either the Artistic License or the
    GNU General Public License, which may be found in the Perl 5 source kit.
    
    Complete documentation for Perl, including FAQ lists, should be found on
    this system using "man perl" or "perldoc perl".  If you have access to the
    Internet, point your browser at http://www.perl.org/, the Perl Home Page.
    
    [root@srv ~]# ls -al /usr/bin/perl /usr/local/bin/perl
    ls: cannot access /usr/local/bin/perl: No such file or directory
    -rwxr-xr-x 2 root root 11400 Nov 20  2015 /usr/bin/perl
    [root@srv ~]# ls -al /usr/local/cpanel/3rdparty/bin/perl
    lrwxrwxrwx 1 root root 44 Aug  1 21:03 /usr/local/cpanel/3rdparty/bin/perl -> /usr/local/cpanel/3rdparty/perl/522/bin/perl
    [root@srv ~]# /scripts/check_cpanel_rpms --fix
    [root@srv ~]# ls -al /usr/bin/perl /usr/local/bin/perl
    ls: cannot access /usr/local/bin/perl: No such file or directory
    -rwxr-xr-x 2 root root 11400 Nov 20  2015 /usr/bin/perl
    [root@srv ~]#


    I see this in the upgrade log, I don't know if its related.

    Code:
    WARNING: "pear/XML_RPC" is deprecated in favor of "pear/XML_RPC2"
     Could not download from "https://de.pear.php.net/get/XML_RPC-1.5.5.tgz", cannot download "pear/XML_RPC" (Connection to `de.pear.php.net:443' failed: )
     Error: cannot download "pear/XML_RPC"
     Download failed
     upgrade failed
    site doesn't have valid SSL cert so fails.



    A httpd error

    Code:
    [Starting apache]
     Disabled scgi-bin since suexec is enabled or the webserver runs as the user
     The system was unable to install httpd. The system was unable to find the script in /usr/local/cpanel/etc/init/scripts/systemd.
     enable was successful
     Missing include file: /etc/apache2/conf.d/includes/pre_main_2.conf
     Rebuilding httpd.conf to add missing include file.
     Updating default: pidfile
     Updating default: group
     Updating default: extendedstatus
     Updating default: loglevel
     Updating default: serveradmin
     Updating default: servername
     Updating default: serversignature
    Thanks
     
    #4 Gavo, Aug 2, 2016
    Last edited: Aug 2, 2016
Loading...

Share This Page