The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim delays

Discussion in 'General Discussion' started by bluedog, May 21, 2003.

  1. bluedog

    bluedog Member

    Joined:
    Aug 20, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Did a search on Exim and saw SEVERAL postss about delivery delays and now we are starting to expierence it on our server. It is delaying email that is local to the server??? Server load is less then 0.81 any ideas? It is starting to queue up pretty rapidly now.

    Btw is this the best place for questions? It seems a lot of posts go unanswered and questions arene't answered too rapidly.

    cPanel.net Support Ticket Number:
     
  2. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bay Area, CA
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    On the Exim issue .. Nick and I spent a full hour on that. We looked at 3 cases of local mail in cue for my boxs. all 3 were delayed for locked pop sessions. Well all 3 in my case were sitting less than 1 hour. Nick told me that the retry for exim was changed by default to 1 hour (down from 15 minutes). on the spot he added a feature in "tweak settings" for mail retry. It works. However since then I have noticed local mail being stuck still in there for well over the 20 minutes I set mine to. Mail will run again at the set interval but it's like it skips over local bound mail. I will work with Nick on this. It's a big deal to many of us. Especially for mail that could deliver in a micro second.

    cPanel.net Support Ticket Number:
     
  4. heavypredator

    heavypredator Well-Known Member

    Joined:
    May 2, 2003
    Messages:
    93
    Likes Received:
    1
    Trophy Points:
    8
    i fixed it commenting these:

    #deliver_load_max = 3
    #deliver_queue_load_max = 5
    #queue_only_load = 4

    my queue is so fast now that i cant mostly see what is it sending

    cPanel.net Support Ticket Number:
     
  5. bluedog

    bluedog Member

    Joined:
    Aug 20, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Thank you guys I will try those changes, and thanks for the response I was really expecting this thread to go as a 0 reply thread.

    Hmmm... This may not be related to my original problem but still a mail queue problem does anyone know why on some emails it says hostlookup did not complete but then if I try to send again in the next 5 seconds it works? Is there a TTL setting I am missing or something?

    cPanel.net Support Ticket Number:
     
    #5 bluedog, May 22, 2003
    Last edited: May 22, 2003
  6. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    You could also /etc/init.d/exim to change the -q into a -qf so that exim will attempt a delivery for each mail in the queue (as opposed to waiting for the default retry time which you can see w/exinext)

    also might be interested in looking at the retry section in exim.conf (if you haven't already)

    cPanel.net Support Ticket Number:
     
  7. bluedog

    bluedog Member

    Joined:
    Aug 20, 2002
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Howard thank you for your suggestion already looked into the retry time in EXIM, but didn't know about your first suggestion. I will look into that as well thank you.

    So far with these changes everything seems to be working fine. I would like to know the 'tweak settings' 'change that was made, but I can wait till it is resolved.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page