The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Delays

Discussion in 'General Discussion' started by DigiCrime, Apr 10, 2005.

  1. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    im curious as to why exim delays emails when accounts are set to blackhole but yet the unrouted email sits in a queue for as much as 2 days. Why does email sit there for so long? I have it configured to run even with the load being high... ignore bounce errorrs after a few hours, etc etc and still stays there :confused:
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    One of the many reasons for not using :blackhole:
    http://www.configserver.com/free/fail.html

    Remember, mail accepted using :blackhole: is processed through the whole of exim and only the last act is to delete it. That means it has still to go through all the checks a normal email has to and it's very common to see queues with tens of thousands of emails in them because people still mistakenly use :blackhole: when it is the last thing you should use.
     
  3. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    I would assume using blackhole would be the best option because unrouted email would be deleted on the go where as failed email has no where to go or bounce back to if its non legit email, therefor email would be stuck in the queue, and the ignore email after so many days or hours still doesnt appear to have any effect as Im still seeing emails up to 7-10 days old. maybe i not fully understanding :D. I had already cleaned out a email queue or I would copy and paste an example.

    Im pretty sure Ive tried :fail: over blackhole and it was worse but Ill doublecheck again and see how that options actually works. My ideal exim setup would be to delete emails after atleast 24 hours if it as no where to go at all :confused:

    thanks as always for your input
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I've explained the reasons for using :fail: over :blackhole: in the link that I posted. It's been proven quita correct now ;)
     
Loading...

Share This Page