Exim - DNS list lookup defer for RBL server

garconcn

Well-Known Member
Oct 29, 2009
172
18
68
We use our own RBL in cPanel. We found that sometimes it catches the IP by the RBL, sometimes it shows DNS lookup error. The RBL server is not busy at all, and we have RBL dns entry in the cpanel server host file. Any idea why the DNS lookup timeout? Thank you.

2014-05-20 14:18:03 DNS list lookup defer (probably timeout) for 129.64.xx.xx.rbl.domain.com: assumed not in list
2014-05-20 14:18:03 DNS list lookup defer (probably timeout) for 129.64.xx.xx.rbl.domain.com: assumed not in list
2014-05-20 14:18:03 DNS list lookup defer (probably timeout) for 129.64.xx.xx.rbl.domain.com: assumed not in list
2014-05-20 14:19:07 DNS list lookup defer (probably timeout) for 44.22.xx.xx.rbl.domain.com: assumed not in list
2014-05-20 14:19:08 DNS list lookup defer (probably timeout) for 44.22.xx.xx.rbl.domain.com: assumed not in list
2014-05-20 14:19:08 DNS list lookup defer (probably timeout) for 44.22.xx.xx.rbl.domain.com: assumed not in list
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello :)

You may want to consider setting up a zone forwarder within /etc/named.conf in the "localhost_resolver" view forwarding all requests for the RBL to the appropriate server.

Thank you.
 

garconcn

Well-Known Member
Oct 29, 2009
172
18
68
Hello :)

You may want to consider setting up a zone forwarder within /etc/named.conf in the "localhost_resolver" view forwarding all requests for the RBL to the appropriate server.

Thank you.
Hi Michael,

Thank you for your advice.

Do you mean to add this to the cpanel named.conf file in "localhost_resover" view section?

Code:
zone "rbl.domain.com" IN {
 type forward;
 forward only;
 forwarders {
 rbl_ip port 53;
 };
};
In cpanel, I have the default config.

Code:
view "localhost_resolver" {
/* This view sets up named to be a localhost resolver ( caching only nameserver ).
 * If all you want is a caching-only nameserver, then you need only define this view:
 */
    match-clients         { 127.0.0.0/24; };
    match-destinations    { localhost; };
    recursion yes;

    zone "." IN {
        type hint;
        file "/var/named/named.ca";
    };

    /* these are zones that contain definitions for all the localhost
     * names and addresses, as recommended in RFC1912 - these names should
     * ONLY be served to localhost clients:
     */
    include "/var/named/named.rfc1912.zones";
};
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Yes, could you let us know if adding such an entry helps?

Thank you.
 

garconcn

Well-Known Member
Oct 29, 2009
172
18
68
Just an update to this issue. Adding the zone forwarder within /etc/named.conf in the "localhost_resolver" in cpanel server did not work for me, however adding the same zone forwarder in my resolver server under view "internal" fixed it. Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Just an update to this issue. Adding the zone forwarder within /etc/named.conf in the "localhost_resolver" in cpanel server did not work for me, however adding the same zone forwarder in my resolver server under view "internal" fixed it. Thanks.
I am happy to see the issue was resolved. Thank you for updating us with the outcome.