Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim doesn't send emails from the account's dedicated IP address

Discussion in 'E-mail Discussion' started by krava, Apr 22, 2013.

  1. krava

    krava Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    Hi guys,

    I have a problem with Exim. It doesn't send emails from the account's dedicated IP address even when the options:

    "Send mail from account’s dedicated IP address"

    OR

    "Reference /etc/mailhelo for outgoing SMTP HELO"
    "Reference /etc/mailips for outgoing SMTP connections"

    are enabled in "Exim configuration editor" of cPanel. I double checked the files /etc/mailhelo, /etc/mailips and they look good.

    The server operates under Centos 6.4 (64bit) and WHM 11.36.0 (build 21). Does anyone else except me experience the same problem ?

    Just to clarify:

    The emails sent by me from the accounts with the dedicated IP addresses reach their recipients just fine but according to the mail headers of the received emails the source mail server established mail session to the destination mail hosts from the shared IP address.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 krava, Apr 22, 2013
    Last edited: Apr 22, 2013
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,513
    Likes Received:
    424
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. krava

    krava Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    I followed the instructions provided at the page:
    Changing the Sending IP for Outbound Email in Exim
    before I opened the thread.

    Currently I have the option "Send mail from account’s dedicated IP address" enabled. So now the files:
    /etc/mailips
    /etc/mailhelo
    are managed by cPanel automatically. The content of the above files is fine (it looks like content from DOCs) but when I send the email from the email address of the account with the dedicated IP the mail headers demonstrate that the server sends the email from the shared IP address and not from the dedicated IP assigned to the account. I check the mail headers on the destination mail host.

    Please note I didn't modify the file /etc/mailips manually. It was generated by cPanel.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,513
    Likes Received:
    424
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I can't duplicate this here, exactly, I don't have a server running STABLE, ATM. But I did do some testing on a new server and cannot duplicate this issue. Is your EXIM configuration also default generated by cPanel?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. krava

    krava Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    I didn't modify the exim's configs manually. Anyway, I reset the exim's config files to default using the option:

    WHM --> Exim configuration manager -- > Reset --> Reset the entire Exim configuration to the default settings provided with cPanel & WHM (3rd party and custom ACLs were disabled too)

    then I opened "Exim configuration manager" again, clicked the tab "Basic editor" and enabled the option "Send mail from account’s dedicated IP address". Other options remained untouched, saved the settings and sent one more test email.

    Unfortunately it hasn't solved the problem.

    Is it better to open a support ticket ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,513
    Likes Received:
    424
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes, I would suggest you open a ticket so that Technical Support can have a closer look at this for you. If you do, please post the ticket ID here if you don't mind so that we can follow it from here.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. compufixpro

    compufixpro Registered

    Joined:
    Jan 17, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    We are having the same issue and have also followed the same path. In addition we have mail_reverse_dns correct as well. We simply can't get exim to use dedicated ips for any domains on WHM. Any input would be appreciated. Thanks!
     
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please open a ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. snazio

    snazio Registered

    Joined:
    Aug 10, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    What fix to solve this problem?

     
  10. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you having the exact same issue and have you completed the same steps as the original poster? If so, you can open a ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. websnail.net

    websnail.net Active Member

    Joined:
    Mar 24, 2002
    Messages:
    39
    Likes Received:
    1
    Trophy Points:
    308
    Identified the most likely cause.

    I hit the exact same issue as everyone else and looking at the details I realised that I was using a redirected domain for my email address.

    eg: foo.co.uk was pointed at foo.com

    foo.com was the primary account with a dedicated IP

    Sending email from: foo@foo.co.uk was all sent via the shared IP.

    Updating the /etc/mailhelo to point

    foo.co.uk: foo.com

    ... resulted in the domain being correctly identified instead of the servers main domain ID, but still sent from the shared IP.

    ----

    Updating the /etc/mailips to add:

    foo.co.uk: [dedi ip for foo.com]

    ...fixed the issue and now all emails from foo.co.uk are sent using the dedicated IP for foo.com


    So, basically Cpanels fix does not automatically add any pointed domains to the files as shown as above.. You'll need to add them yourself.
     
  12. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,142
    Likes Received:
    1,932
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    What version of cPanel did you reproduce this issue on? Note that internal case FB-109129 (not yet released) aims to address an issue where when the option is enabled for accounts to send out mail over dedicated IP addresses, if accounts are owned by a reseller with a different "Reseller Shared IP", it will ignore the domain account's IP address and use the reseller shared IP address in /etc/mailips.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice