The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Down On New Server

Discussion in 'General Discussion' started by rlshosting, Feb 16, 2013.

  1. rlshosting

    rlshosting Well-Known Member

    Joined:
    Apr 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    I have a new dedicated server and exim is down. I am on current which is version 11.36.0 Build 9. How do I fix this? I tried resetting it and it says exim has failed. Dovecot works and Mailman works.

    exim exim-4.80-4.cp1136.x86_64 down
    exim-26 down
     
  2. Jeff Shotnik

    Jeff Shotnik Well-Known Member

    Joined:
    Oct 10, 2012
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Denver, Colorado, United States
    cPanel Access Level:
    DataCenter Provider
    Did you also try `/scripts/eximup --force`?
     
  3. rlshosting

    rlshosting Well-Known Member

    Joined:
    Apr 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    Yes. I tried that.
     
  4. Jeff Shotnik

    Jeff Shotnik Well-Known Member

    Joined:
    Oct 10, 2012
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Denver, Colorado, United States
    cPanel Access Level:
    DataCenter Provider
    What is logged in /var/log/exim_mainlog when you try a restart on the service?
     
  5. rlshosting

    rlshosting Well-Known Member

    Joined:
    Apr 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    Here you go.

     
  6. Jeff Shotnik

    Jeff Shotnik Well-Known Member

    Joined:
    Oct 10, 2012
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Denver, Colorado, United States
    cPanel Access Level:
    DataCenter Provider
    There you go:

    "socket bind() to port 25 for address (any IPv6) failed: Address already in use: waiting 30s before trying again (8 more tries)"

    run `lsof -i:25` and kill the process using port 25.
     
  7. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    You could try:
    perl /scripts/checkexim.pl
     
  8. rlshosting

    rlshosting Well-Known Member

    Joined:
    Apr 23, 2009
    Messages:
    170
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    I just rebooted the server and now it's fine. Thanks everyone for helping!
     
    #8 rlshosting, Feb 16, 2013
    Last edited: Feb 16, 2013
Loading...

Share This Page