The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim error - cant send any email

Discussion in 'E-mail Discussions' started by truongton, Jul 21, 2005.

  1. truongton

    truongton Registered

    Joined:
    Jul 17, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    hoangtuphale84@yahoo.com
    unrouteable mail domain "yahoo.com"

    --------------------------------------
    In SSH i type tail -f /var/log/exim_paniclog
    and it show this



    1DvfR7-0003ga-90 failed to expand condition "${perl{checkspam}}" for lookuphost router: Undefined subroutine &main::checkspam called.

    2005-07-22 01:06:21 1DvfR7-0003ga-90 failed to expand condition "${perl{checkspam}}" for literal router: Undefined subroutine &main::checkspam called.

    2005-07-22 01:06:21 1DvfR7-0003gc-Ag failed to expand condition "${perl{checkusersa}{$local_part}{$received_protocol}}" for sa_localuser router: Undefined subroutine &main::checkusersa called.

    2005-07-22 01:06:21 1DvfR7-0003gc-Ag failed to expand condition "${perl{hasfilterfile}{$local_part}}" for central_user_filter router: Undefined subroutine &main::hasfilterfile called.

    2005-07-22 01:06:21 1DvfR7-0003gc-Ag failed to expand condition "${perl{checkuserspambox}{$local_part}}" for localuser_spam router: Undefined subroutine &main::checkuserspambox called.

    -------------------------------------------------
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    Try /scripts/eximup --force
     
  3. truongton

    truongton Registered

    Joined:
    Jul 17, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have use /scripts/eximup --force
    And now my server is back to that error again after 2 day run fine. Any idea? :( :(
     
    #3 truongton, Jul 24, 2005
    Last edited: Jul 24, 2005
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    you might need to switch the cpanel to edge and make an upcp forcefully

    also you can keep the automatic update turned off for the moment.
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Did you install/use SRBL or ACL rules? If yes, you'll need to either remove these rules or fix them to get rid of that error message.
     
  6. challii

    challii Well-Known Member

    Joined:
    Feb 3, 2004
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
    I'm 99% sure thats the error message you get when you go over the max number of emails an hour. try raising that / tracking down the email.
     
  7. A_I

    A_I Registered

    Joined:
    Jul 26, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    We are having the same problems.
    And besides exi.pl amd exim.conf files disapear.
    exim.conf we have restore, but what we can do with exim.pl?
     
  8. A_I

    A_I Registered

    Joined:
    Jul 26, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
Loading...

Share This Page