The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Error

Discussion in 'General Discussion' started by B12Org, Nov 6, 2003.

  1. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    I did a servcice cpanel stop; service cpanel start command and it gave me the following errors. I dont know what they mean besides what they say here, so any help would be appreciated. I am mainly concerned with the errors about exim, as that could prove to be a problem later on.


    root@server1 [~]# service cpanel stop; service cpanel start
    Stopping cPanel services: [ OK ]
    Stopping webmail services: [ OK ]
    Stopping pop3 services: [ OK ]
    Stopping cPanel log services: [FAILED]
    Stopping cPanel Chat services: [ OK ]
    Stopping Melange Chat services: [ OK ]
    Stopping InterChange services: [ OK ]
    Stopping cPanel ssl services: [FAILED]
    Stopping Web Host Manger services: [ OK ]
    Stopping mailman services: Shutting down Mailman's master qrunner

    Starting SMTP Tweak: [ OK ]
    Starting eximstats: Can't locate DBI.pm in @INC (@INC contains: /usr/lib/perl5/5
    .6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /
    usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site
    _perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6
    .1 /usr/lib/perl5/vendor_perl .) at /usr/lib/perl5/site_perl/5.6.1/i386-linux/DB
    D/mysql.pm line 7.
    BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.6.1/i386-linux/D
    BD/mysql.pm line 7.
    Compilation failed in require at /usr/local/cpanel/bin/eximstats line 252.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/eximstats line 252.
    [FAILED]
    Starting cPanel services: [ OK ]
    Starting WebMail services: [ OK ]
    Starting pop3 services: [ OK ]
    Starting cPanel Chat services: [ OK ]
    Starting Melange Chat services: [ OK ]
    Starting InterChange services: [ OK ]
    Starting cPanel ssl services: [ OK ]
    Starting Web Host Manager services: [ OK ]
    Starting mailman services: Starting Mailman's master qrunner.

    root@server1 [~]# The Interchange server was not running (/usr/local/cpanel/3rdparty/interchange/etc/interchange.pid).
    Low traffic settings.
     
  2. RaveKnights

    RaveKnights Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Some Where Out There!
    I would download /usr/local/cpanel/bin/eximstats and look at line 252 and see what it is looking for.

    perhaps it will tell you where DBI.pm is supposed to be located.

    do a search on your server

    locate DBI.pm and if you find it than cp it to where eximstats is supposed to find it.
     
  3. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    This is all it says:

    sub dbconnect {

    use DBD::mysql;
    use Socket;
    use Sys::Hostname;

    $dbh =
    DBI->connect("DBI:mysql:$database:$dbhost","$dbuser","$dbpassword");
    unless ($dbh) {
    die("Can't Connect");}
    };



    And DBI.pm is located at the following:





    /usr/lib/perl5/site_perl/5.6.1/i386-linux/Template/Plugin/DBI.pm
    /usr/lib/perl5/site_perl/5.6.1/Persistent/DBI.pm
    /usr/lib/perl5/site_perl/5.8.1/i686-linux/DBI.pm
    /usr/lib/perl5/site_perl/5.8.1/i686-linux/Bundle/DBI.pm
    /usr/lib/perl5/site_perl/5.8.1/Apache/AuthDBI.pm
    /usr/lib/perl5/site_perl/5.8.1/Apache/DBI.pm
    /usr/lib/perl5/site_perl/5.8.1/AI/Categorizer/Collection/DBI.pm
    /usr/local/cpanel/3rdparty/interchange/lib/Vend/Table/DBI.pm
    /home/.cpan/Bundle/DBI.pm
    /home/eluded/public_html/cgi-bin/mt/lib/MT/ObjectDriver/DBI.pm
    /home/isism/public_html/lib/MT/ObjectDriver/DBI.pm
    /home/nukedwha/public_html/blog/cgi-bin/lib/MT/ObjectDriver/DBI.pm
     
  4. RaveKnights

    RaveKnights Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Some Where Out There!
    OK so you should run this command

    /usr/local/cpanel/bin/checkperlmodules


    after that than run

    service cpanel restart

    see if the problem still exist
     
  5. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    This is what I did

    rm -rf /usr/local/cpanel/cpanel
    (yes I deleted the cpanel core to force a master update)

    /scripts/updatenow
    /scripts/upcp

    wait a while to finish then

    /scripts/exim4
    /scripts/updateuserdomains2
    /scripts/mailperm

    Plus the two that you mentioned. That error seemed to go away after that, however I am testing email, and I sent one from a non server account to a server account, and it never showed up. It is also not sitting in the mail queue.
     
  6. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    I even sent an email from a server account to a server account (same domain) and it never showed up delivered or in the queue either. Very odd.
     
  7. RaveKnights

    RaveKnights Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Some Where Out There!
    How did you upgrade your perl?

    somewhere along the line your perl must have broke
    did you run the command that I suggested first before you forced an restall?
     
  8. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    No, I ran those other commands first.
     
  9. RaveKnights

    RaveKnights Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Some Where Out There!
    Well I'm lost to why your exim is not working now.

    Any one else has any clues to shed some light on this..
     
  10. B12Org

    B12Org Well-Known Member

    Joined:
    Jul 15, 2003
    Messages:
    692
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle Washington
    cPanel Access Level:
    Root Administrator
    I downloaded the perl module from layer1.cpanel.net and installed it on the server. I have done it a few times, and it exim was working fine. Then bind broke, and after it was fixed, it is just black holing everything.
     
Loading...

Share This Page