Exim (/etc/localdomains) problem after recent update

sh3lls.net

Member
May 15, 2004
5
0
151
India
Hello
After recent cpanel/whm update, now if i change the MX record for a domain as i'm using spam filtering service from mailroute.net, i've to setup their MX record and have to setup exim to even accept emails, so that after filtering mailroute.net will forward them to my server. Now as soon as i change MX record, cpanel even removes the domain from /etc/localdomains and hence exim stops accepting email for that particular domain, how do i fix it. I even tried to add domain to it manually, but within 24 hours the domain is automatically removed from /etc/localdomains

I need either that exim should just accept emails from just mailroute.net mail server and deny emails from other servers and also i don't want the domain to get removed from /etc/localdomains.

I don't want to block port 25 as i even have other domains on the same server.

Please guide

Best Regards
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
Make sure the domain is not listed in /etc/remotedomains, that's why it's probably getting removed from /etc/localdomains. If you only want to receive email for a particular domain from a specific IP address then you'll have to write an exim ACL to do that for you.
 

adapter

Well-Known Member
PartnerNOC
Sep 17, 2003
391
0
166
yes it was in /etc/remotedomains why?

the customer have change the mx record to use a proxy antispam, every time that he change the MX the domain is removed from localdomains and this cause a relay error
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
cPanel automatically puts a domain into /etc/remotedomains if the MX record is changed through the end-user cPanel UI. It does this because when you point an MX to a different server you want the email delivered off-server, otherwise any email delivered to that domain locally from any other account on the server will be delivered to the mailboxes on the server and not via the MX record.
 

Neil-UKWSD

Registered
Sep 16, 2004
3
0
151
Hi,

We've opened a bug/feature request for this in WHM, with cPanel 10 we could edit the dns zone template so new accounts were auto setup to use of spam filtering service but since the changes to cPanel 11 if we do this the domain is put in the remote domains file.

The same now happens if you edit a DNS zone in WHM and it has the MX record set to an external record. We need some way to disable this automated move to remotedomains when editing the DNS zones and when using the zone templates to configure the spam filtering setup.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
Hi,

We've opened a bug/feature request for this in WHM, with cPanel 10 we could edit the dns zone template so new accounts were auto setup to use of spam filtering service but since the changes to cPanel 11 if we do this the domain is put in the remote domains file.

The same now happens if you edit a DNS zone in WHM and it has the MX record set to an external record. We need some way to disable this automated move to remotedomains when editing the DNS zones and when using the zone templates to configure the spam filtering setup.
If you use the mx editor you have the option to not do the remote domains check.
 

aboleth

Well-Known Member
Sep 8, 2005
50
0
156
Even though I did have 3 domains dissapear from /etc/localdomains, I'd say the new interface for handling MX records is vastly improved. I was hoping something like this would be added. Besides this problem, I've had no other issues with 11.

I'd say good job overall to the CPanel staff.