Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim :fail: :blackhole: not relaying messages

Discussion in 'General Discussion' started by leighj, Mar 28, 2005.

  1. leighj

    leighj Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    This is NOT a discussion on why blackhole is bad

    With :fail: or :blackhole: messages sent to the main account OR to a forward are being failed or blackholed also.

    Going on the server and emailing the user directly works.

    While this has reduced spam messages are being LOST when I send directly to the main account for a domain.

    I am running Release 161
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    If you used to use the main account and had the Default Address set to forward and then subsequently set it to :fail: or :blackhole: you must create a virtual POP3 account called account@domain.com within cPanel > Mail > Manage/Add/Remove Accounts, and then use the username account@domain.com to login to collect the POP3 mail instead of just account.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leighj

    leighj Well-Known Member

    Joined:
    Feb 21, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    Resolution

    The account was setup with the the defaults.

    username was the default address

    Then several forwards were added

    forward1@hostname.com
    forward2@hostname.com
    forward3@hostname.com

    And all was good

    Then changed the default address to :fail: :blackhole:

    No emails for username OR through the forwards.

    Is the solution to create a account
    username@hostname.com and check the email there?

    I had some of my techs look at the problem and their resoultion was to

    fixed the issue by adding the line username@hostname.com: username before the line for fail inside /etc/valiases/hostname.com. What is happening is that when a mail is sent to username@hostname.com the email server will not find an inbox for the account and will redirect the mail to the default catch all which is set to :fail:. By adding the line username@hostname.com: username the mails routed for username@hostname.com will be delivered inside the mail box for the account username.

    So that the valiases file for the site looked like
    Code:
    forward1@hostname.com: username@hostname.com
    username@hostname.com: username
    forward2@hostname.com: username@hostname.com
    forward3@hostname.com: username@hostname.com
    forward4@hostname.com: username@hostname.com
    *: :fail:
    Which makes a LOT more sense as this would indicate that Cpanel is not setting the username@hostname.com

    The strange thing is that this WAS working and now isn't or am I mistaken? :confused:
     
    #3 leighj, Mar 28, 2005
    Last edited: Mar 28, 2005
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Yes, that is the normal solution.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice