Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim failed, 5.6 gig maillog.1

Discussion in 'E-mail Discussion' started by Man0warr, Sep 7, 2006.

  1. Man0warr

    Man0warr Well-Known Member

    Joined:
    Jun 5, 2006
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Dallas, TX
    At like 8:45pm Exim failed, then around 9 we got this e-mail:

    I didn't think much of it at the time, as 2.6 load wasn't huge.

    Around midnight we got some /var drive space warnings.

    I couldn't figure out what was going wrong, so I went to check the maillogs. Maillog.1 was 5.6gigs! We rotate nightly, and keep up to 15 days. I tried to move maillog.1 out of /var to somewhere with more drive space, wouldn't let me.

    All the time exim is down, the load was up to like 14 now, I couldn't get exim to restart. When I deleted maillog.1 I was able to restart exim and the load went down.

    During this time, clients could still get e-mail but couldn't send, so I was getting alot of calls.

    Everything seems to be back to normal now, but the maillogs and other logs had been rotating fine for months and I STILL don't know what caused this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. celliott

    celliott Well-Known Member

    Joined:
    Jan 2, 2006
    Messages:
    460
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    United Kingdom
    Have you got SMTP Tweak Enabled, or are you allowing "Nobody" to send mail?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    That's likely to be a problem with logrotate. Do you have your /tmp mounted noexec? If so, thne there's a know problem with logrotate that can break things. To workaround it you need to setup a TMPDIR for logrotate to avoid the problem:

    You can do this by editing /etc/cron.daily/logrotate so that it looks like this:

    Code:
    #!/bin/sh
    
    if [ ! -e "/logrotate_tmp" ]; then
    	mkdir /logrotate_tmp
    fi
    export TMPDIR=/logrotate_tmp
    
    /usr/sbin/logrotate /etc/logrotate.conf
    EXITVALUE=$?
    if [ $EXITVALUE != 0 ]; then
        /usr/bin/logger -t logrotate "ALERT exited abnormally with [$EXITVALUE]"
    fi
    exit 0
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Man0warr

    Man0warr Well-Known Member

    Joined:
    Jun 5, 2006
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Dallas, TX
    Why would this happen all of a sudden though? It's been rotating fine since I set it up.

    I don't think /tmp is set to noexec,

    /dev/hda8/ on /tmp type ext3 (rw)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 Man0warr, Sep 7, 2006
    Last edited: Sep 7, 2006
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Since you don't have to noexec option (from that mount output) what I mentioned shouldn't be the issue. However, the fact it was logging to maillog.1 does mean that logrotate failed for some reason. If you ever see that happening again, restart syslog
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice