The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Failed, cpanel not working after reboot

Discussion in 'General Discussion' started by TonyBenn, Feb 3, 2009.

  1. TonyBenn

    TonyBenn Member

    Joined:
    Jan 14, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    cPanel 11.24.4-R33609 - WHM 11.24.2 - X 3.9
    FREEBSD 6.2 i386 on standard

    I noticed that mail was not being delivered this morning, so I decided to take a look. Exim wouldn't restart, the queue was empty, so I tried a graceful reboot.

    Mysql then failed, and WHM wouldn't start.

    I tried this:
    /etc/init.d/cpanel restart

    and it looks like its running through a build.

    Mysql just came back up in the middle of it, but mail doesn't seem to be delivered yet. I've also noticed that my rc.conf was edited last night, presume this was an upgrade.

    Can anyone help me? Where should I look to diagnose exim?

    B
     
  2. TonyBenn

    TonyBenn Member

    Joined:
    Jan 14, 2007
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    OK problem solved. I've no idea what caused it, presume the update last night!

    I got this trying to restart exim:

    root@/var/log/exim$> /scripts/restartsrv_exim
    info [restartsrv_exim] BSD::Resource not available. Resource Limits not adjusted
    /libexec/ld-elf.so.1: Shared object "libperl.so" not found, required by "exim"

    and then fixed the perl problem with this:
    /usr/local/bin/perl-after-upgrade -f

    Restart exim and all was OK.

    Hope this helps...

    B
     
Loading...

Share This Page