The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim failed !! in big mess !! Error:package exim is not installed

Discussion in 'General Discussion' started by atul, Jun 24, 2004.

  1. atul

    atul Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Hello All,
    Yesterday I tried to upgarde cpanel on my RedHat 7.3 server.Fortunately it upgraded the cpanel to 9.4 version but left me in bigger mess.When I looked in service status i found exim,imap both failed(showing red balls).
    Along with exim it is showing message that package exim is not installed.Now I am wondering how this happened?.I upgraded the cpanel only nothing else to 9.4.
    I tried to build apache and upgarding cpanel so that exim get installed but it failed.
    I tried /scripts/exim3 and /scripts/exim4 but they are ginving error:

    Resetting Exim to cPanel Defaults and Installing the Latest Version
    `/etc/localdomains' -> `/etc/localdomains.eximreset'
    error: package exim is not installed
    Retrieving http://diff.cpanel.net/exim-cpanel6.5.0/exim-3.36-155_cpanel_stmpcontrol_antivirus_rewrite.i386.rpm
    /scripts/exim3: line 30: 7909 Segmentation fault (core dumped) rpm -Uvh http://diff.cpanel.net/exim-cpanel6.5.0/exim-3.36-155_cpanel_stmpcontrol_antivirus_rewrite.i386.rpm
    `/etc/localdomains.eximreset' -> `/etc/localdomains'
    Waiting for exim to restart..............finished.



    exim has failed, please contact the sysadmin.
    What is problem?How should I install exim package and get imao etc working on server?
    Please help!!
    Thank you
     
  2. wayneb

    wayneb Member

    Joined:
    Aug 26, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I don't have any answer but I am also having problems
    with exim.

    My exim stopped working and I can't figure it out. After it stopped
    working, I installed the newest version 4.34-60 and still can't get
    it working. Get the following:

    Jun 24 22:09:16 server145 exim: clamd shutdown succeeded Jun 24 22:09:16 server145 exim: exim shutdown failed Jun 24 22:09:16 server145 exim: antirelayd shutdown succeeded Jun 24 22:09:17 server145 exim: spamd shutdown succeeded Jun 24 22:09:17 server145 exim: clamd shutdown failed Jun 24 22:09:17 server145 exim: exim shutdown failed Jun 24 22:09:17 server145 exim: antirelayd shutdown failed Jun 24 22:09:17 server145 exim: spamd shutdown failed Jun 24 22:09:17 server145 exim: clamd shutdown failed Jun 24 22:09:17 server145 exim: exim shutdown failed Jun 24 22:09:17 server145 exim: antirelayd shutdown failed Jun 24 22:09:17 server145 exim: spamd shutdown failed Jun 24 22:09:18 server145 exim: clamd startup succeeded Jun 24 22:09:18 server145 exim: exim startup succeeded Jun 24 22:09:19 server145 exim: antirelayd startup succeeded Jun 24 22:09:20 server145 exim: spamd startup succeeded exim has failed, please contact the sysadmin.

    When I restart exim through ssh it shows everything stopping and
    starting ok, but when I go to the CPanel WHM it still shows exim has
    failed.
     
  3. bangsters

    bangsters Well-Known Member

    Joined:
    Jun 28, 2004
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    same problem with me....i installed fedora and exim is not installed....i checked the rpm packages and nothing is there....no rpms of anny kind just blank....how do i get exim???
     
  4. eazistore

    eazistore Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Singapore
    exim fail

    Hi,

    same problem here.
    I restart EXIM via WHM and i got this error:
    Jul 10 11:09:04 server exim: clamd shutdown succeeded Jul 10 11:09:08 server exim: exim shutdown failed Jul 10 11:09:08 server exim: antirelayd shutdown succeeded Jul 10 11:09:09 server exim: spamd shutdown succeeded Jul 10 11:09:09 server exim: clamd shutdown failed Jul 10 11:09:13 server exim: exim shutdown failed Jul 10 11:09:13 server exim: antirelayd shutdown failed Jul 10 11:09:14 server exim: spamd shutdown failed Jul 10 11:09:14 server exim: clamd shutdown failed Jul 10 11:09:18 server exim: exim shutdown failed Jul 10 11:09:18 server exim: antirelayd shutdown failed Jul 10 11:09:18 server exim: spamd shutdown failed exim has failed, please contact the sysadmin.

    Any clue yet?
     
  5. vea

    vea Registered

    Joined:
    Jul 14, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here. running fedora core 1
     
  6. bangsters

    bangsters Well-Known Member

    Joined:
    Jun 28, 2004
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    i switched to RH9 and everything is fixed now....
     
Loading...

Share This Page