The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim - failed to find host name from IP address

Discussion in 'General Discussion' started by pfmartin, Feb 14, 2002.

  1. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    I have several clients that are not able to send email at sporadic times. Outlook as usual gives some error that has nothing to do with anything or any entry in the KB that gives no real information.

    I managed to track down the problem by checking the logs. Here is a sample:

    2002-02-14 11:12:00 refused relay (host) to &MAlsbrook@xxxxx.com& from &daniel@xxxxx.net& H=(atldxxxxxlt01) [172.144.82.xx] (failed to find host name from IP address)

    This is an AOL dialup account.

    By the way, it also happens on bellsouth, etc. So it's not specific to AOL.

    Funny thing is that the user logged out, then back in and then was able to send email. It's as if certain IP's don;t work.

    What is this? Is it my DNS servers? What could be causing exim to not resolve an IP and fail to relay?
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    a setting in the /etc/exim.conf actually

    .................

    # The setting below causes Exim to do a reverse DNS lookup on all incoming
    # IP calls, in order to get the true host name. If you feel this is too
    # expensive, you can specify the networks for which a lookup is done, or
    # remove the setting entirely.

    host_lookup = 0.0.0.0/0

    ..........................................

    Reverse dns is always helpful for smtp servers to communicate- some require it. I am not sure if this is causing an actual problem though, it only seems to kick in when your antirelayd is dead and /etc/relayhosts wasn't being built.

    So.... /scripts/fixrelayd
     
  3. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Thank you for the info. I actually was able to get a solution from Burst. Very simple... doh!

    Set SMTP to authenticate. Enter THE FULL EMAIL ADDRESS. And of course the password. That will solve this.

    My mistake was that when I tried the authentication step, I only entered the username, not the full email address.

    This had to with the fact that you must login to your POP before sending through SMTP. Outlook and other email clients tend to send before checking POP. That is the nature of the problem.

    Thanks for your feedback though.
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Yes that is the whole purpose of antirelayd and the fixrelayd script (that kills syslog and antirelayd and restarts both in sync), it builds /etc/relayhosts with the hostnames of authenticated pop3 users. And exim allows such folks in that file to relay without any SMTP auth.

    Entering the smtp auth is the workaround fix when all else fails, true. It's just more work for customers and as we know outlook settings are like pulling teeth out through your thighs for some people.

    But whatever works ;)
     
Loading...

Share This Page