The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Failing And Restarting...

Discussion in 'E-mail Discussions' started by timvie, Jul 25, 2009.

  1. timvie

    timvie Member

    Joined:
    Aug 15, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Get this email every 5 mins...


    exim failed @ Sat Jul 25 20:12:50 2009. A restart was attempted automagically.
    Service Check Method: [tcp connect]

    Failure Reason: TCP Transaction Log:
    << 220-xxx.xxx.com ESMTP Exim 4.69 #1 Sat, 25 Jul 2009 20:13:13 -0400
    <<
    <<
    >> EHLO localhost
    << 250-xxx.xxx.com Hello localhost [127.0.0.1]
    <<
    <<
    <<
    <<
    <<
    >> AUTH PLAIN AF9fY3BhbmVsX19zZXJ2aWNlX19hdXRoX19leGltX19HM1VoYzFiYmlwWWpscGRVOWpWUzlkbnkzRzlGMmtCbWxBQ055ZnhtYzVMOTR2Y1R1eVdBVEZacU45NEszcVIwAEdieHNzUE5lYTZ0VEpZSnYydHNzaTFZVlhHUzJ6RE1XTmtYc0hUclptX1JkNGg4QThuX1pHNTRUcjJKd2Y3VWY=
    << 435 Unable to authenticate at present
    exim: ** [435 Unable to authenticate at present != 2]

    Seems to send mail ok. Tried the stuff below and it did not fix the issue?

    remove the directory exim

    cd /var/cpanel/serviceauth/
    rm -rf exim

    Restart Cpanel.
    /etc/rc.d/init.d/cpanel restart

    The folder exim will be recreated…

    that should fix the issue.
     
  2. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    I tried this, but the folder exim was NOT recreated :(
     
  3. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
  4. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    Try:

    Code:
    /scripts/eximup --force
    Works for me.
     
  5. danielvargasm

    danielvargasm Registered

    Joined:
    Mar 6, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1

    Not work



    Exim Perl Load List is: spam_acl_support|checkuserquota|boxtrapper|safefile|fast_checkvalias|checkspam|checkspam2|fast_isdemo|fast_accountfunc|checkpass_cphulkd
    /etc/exim.pl.local installed!
    razor2 is not installed, disabling it in SpamAssassin to save memory
    pyzor is not installed, disabling it in SpamAssassin to save memory
    SPF is disabled in exim or unavailable, enabling SPF for SpamAssassin
    exim: no process killed
    Waiting for exim to restart..............finished.

    exim (/usr/sbin/exim -bd -q60m) running as mailnull with PID 19595
    exim (/usr/sbin/exim -q) running as mailnull with PID 19602

    exim has failed, please contact the sysadmin.
    Install Complete
     
  6. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    One of my servers shows the same message any time you restart Exim -- ever since 4.69_25 or whatever the version was that was released to address the first Exim vulnerability around 12-8 or 12-9.

    But, when I check I see that exim is running.

    I wonder if its simply a case where Exim is taking longer to shut down and restart than it used to prior to this latest version and thus the script that checks to see if the server issues a "failed" message because Exim hadn't come up by the time it checked.

    Mike
     
Loading...

Share This Page