The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Failing

Discussion in 'General Discussion' started by Ben-Orbital, Jul 22, 2004.

  1. Ben-Orbital

    Ben-Orbital Member
    PartnerNOC

    Joined:
    Oct 6, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Hi,

    We are having a major problem with exim. All of a sudden it has failed and when you try to restart it still fails. The paniclog and mainlog havent updated since 2 o'clock this morning and are not providing any help with why exim is failing, as they are not updating.

    Tried to run /scripts/exim4 and am getting errors:

    *** Error code 1

    Stop in /usr/ports/mail/exim.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade2210.0 make
    ** Fix the problem and try again.
    ---> Build of mail/exim ended at: Thu, 22 Jul 2004 10:52:44 +0100 (consumed 00:00:00)
    ---> Fresh installation of mail/exim ended at: Thu, 22 Jul 2004 10:52:44 +0100 (consumed 00:00:01)
    ---> Reporting the results (+:done / -:ignored / *:skipped / !:failed)
    ! mail/exim (unknown build error)
    ---> Session ended at: Thu, 22 Jul 2004 10:52:44 +0100 (consumed 00:00:02)
    Waiting for exim to restart..............finished.


    We are currently running: WHM 9.4.0 cPanel 9.4.1-R71 FreeBSD 4.9-RELEASE - WHM X v3.1.0

    I cant seem to find a solution is there anyone that has any ideas or can help. Thanks!!
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Check the following:

    1. That all of the following exist:

    /var/log/exim_mainlog
    /var/log/exim_rejectlog
    /var/log/exim_paniclog

    2. That all the above have the correct file owner of mailnull:mail and permissions of 640

    Then try restarting. If that doesn't work, you should certainly have cPanel take a look at it through a Support Ticket.
     
  3. Ben-Orbital

    Ben-Orbital Member
    PartnerNOC

    Joined:
    Oct 6, 2003
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Yea they exist in /var/log/exim/mainlog, paniclog, rejectlog .

    -rw-r----- 1 mailnull mailnull 108240848 Jul 22 02:15 mainlog
    -rw-r----- 1 mailnull mailnull 2137932 Jul 21 15:57 paniclog
    -rw-r----- 1 mailnull mailnull 15919277 Jul 22 02:11 rejectlog

    Ben
     
  4. Gnomercy

    Gnomercy Well-Known Member
    PartnerNOC

    Joined:
    Sep 4, 2002
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    The permissions on my log files mirrored those listed by Ben-Orbital. I chown'd them to:

    drwxr-xr-x 2 mailnull mailnull 512B Jun 30 19:42 .
    drwxr-xr-x 4 root wheel 2.0K Jul 24 01:00 ..
    -rw-r----- 1 mailnull mail 21M Jul 23 20:34 mainlog
    -rw-r----- 1 mailnull mail 923K Jul 23 18:01 paniclog
    -rw-r----- 1 mailnull mail 13M Jul 23 20:34 rejectlog

    and exim still fails on restart. Anyone else have a solution for this? Cpanel is pretty slow with support tickets on average and I'd like to get this resolved before customers start complaining that they can't send email.

    EDIT: Have tried /scripts/exim4 to no avail.
     
    #4 Gnomercy, Jul 24, 2004
    Last edited: Jul 24, 2004
  5. Gnomercy

    Gnomercy Well-Known Member
    PartnerNOC

    Joined:
    Sep 4, 2002
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Found the fix in this thread here on the cpanel forums. Hope this helps.
     
Loading...

Share This Page