Exim Fails after cPanel Update

ajaydsouza

Active Member
Apr 14, 2006
34
0
231
Hi,

After the daily cPanel update, i.e. after /scripts/updatecp runs Exim fails.

It tries to automagically start and it take a few hours and then starts again. In the process I end up getting 50 to 100 emails saying exim has failed, when it starts working!

This has been happening every single day.

If the cronjob to update is disabled, then exim doesn't fail at all.

I have set cPanel to update automatically with the RELEASE build.

Please help as this has gotten very frustrating :(


Update: I also ran eximup --force
It does the reinstall but at the very end it says "Exim has failed, contact system admin"
 
Last edited:

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
You should check /var/log/exim_mainlog for errors as to why it is failing. One thing is to make sure that you do not run SIM or monit or any other utility other than chkservd to watch/restart application services.
 

ajaydsouza

Active Member
Apr 14, 2006
34
0
231
chirpy said:
You should check /var/log/exim_mainlog for errors as to why it is failing. One thing is to make sure that you do not run SIM or monit or any other utility other than chkservd to watch/restart application services.
I think I got SIM doing that. So should I disable SIM completely or just prevent it from starting EXIM and other services?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
I can't see the point of having SIM running since chkservd does the job, but if you do run it, make sure it doesn't restart any of the processes that chkservd watches.
 

ajaydsouza

Active Member
Apr 14, 2006
34
0
231
chirpy said:
I can't see the point of having SIM running since chkservd does the job, but if you do run it, make sure it doesn't restart any of the processes that chkservd watches.
The opint of SIM was to shutdown a process if it starts to consume a lot of resources.

chkservd would restart it, somehow there was a clash I believe.

I have now disabled SIM from monitoring Exim and have going to monitor this for a few days.

Then will enabled CPanel Daily update once again and see if there is a problem.

Worst case, will just knock of SIM and PRM!