The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim fails continually, no errors

Discussion in 'General Discussion' started by pshepperd, May 10, 2005.

  1. pshepperd

    pshepperd Well-Known Member

    Joined:
    Feb 12, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Exim is delivering mail properly, as well as recieving and sending it. However, it is showing as down (think red dot) , and I get an email every aprox 8 minutes, saying that it failed and was restarted automagically.

    However, this is the truely strange part, there is no error in the logs,
    I have checked
    panic_log
    main_log
    messages
    exim_mainlog

    I do not understand the mechanisms cpanel uses for checking this service, can someone direct me?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The checking daemon is chkservd and it uses the configuration files in /etc/chkserv.d/ you might want to try restarting chkservd (linux):

    service chkservd restart

    As to the problem, which version of exim are you running? If it's anything older than 4.50, then I'd suggest that you upgrade it:

    /scripts/updatenow
    /scripts/exim4
     
  3. pshepperd

    pshepperd Well-Known Member

    Joined:
    Feb 12, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Yup, did all that already. Though the latest FC2 RPM's for exim are 4.3. Shall I build it from source or get dag?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You won't be able to install from source as they're patched by cPanel. However, the latest releases for FC2 are v4.50 not v4.3, you should not be installing them from the FC distribution (you should be excluding them in your yum.conf). Make sure that you have v4.50 installed from cPanel.
     
  5. pshepperd

    pshepperd Well-Known Member

    Joined:
    Feb 12, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Ok, yum has nothing excluded, I just installed this, EXIM is definatly the FC2 RPM and was not installed by cpanel install script ( was done by me after I realized exim wasnt there), however I dont see any errors in the install logs.

    I am thinking re-image the server and try another install? Professional opinions? I never had this problem on a cpanel install before.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No need to reinstall. Add the following to yum.conf:

    exclude=kernel* php* httpd* perl mysql* mod_ssl* imap* squirrelmail* spamassassin* exim*

    Then clean off exim:

    rpm -e --force --nodeps exim

    /scripts/updatenow
    /scripts/eximup --force


    Then you should be fine.
     
  7. pshepperd

    pshepperd Well-Known Member

    Joined:
    Feb 12, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Worked wonderfully thank you sir.
     
Loading...

Share This Page