The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim fails on FreeBSD 6.1

Discussion in 'General Discussion' started by Nevsky, Feb 16, 2007.

  1. Nevsky

    Nevsky Registered

    Joined:
    Jan 4, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello!

    After installation cPanel on a server with FreeBSD 6.1 exim does not work

    Code:
    : undefined reference to `Perl_sv_2pv_flags'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x61): In function `SaveError':
    : undefined reference to `Perl_sv_2pv_flags'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x189): In function `XS_DynaLoader_dl_load_file':
    : undefined reference to `Perl_sv_2pv_flags'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x462): In function `XS_DynaLoader_dl_find_symbol':
    : undefined reference to `Perl_sv_2pv_flags'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x629): more undefined references to `Perl_sv_2pv_flags' follow
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x986): In function `boot_DynaLoader':
    : undefined reference to `Perl_get_sv'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x9c1): In function `boot_DynaLoader':
    : undefined reference to `Perl_get_sv'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x9dc): In function `boot_DynaLoader':
    : undefined reference to `Perl_sv_2pv_flags'
    /usr/local/lib/perl5/5.8.8/mach/auto/DynaLoader/DynaLoader.a(DynaLoader.o)(.text+0x9f1): In function `boot_DynaLoader':
    : undefined reference to `Perl_sv_2pv_flags'
    *** Error code 1
    
    Stop in /usr/ports/mail/exim/work/exim-4.66/build-FreeBSD-i386.
    *** Error code 1
    
    Stop in /usr/ports/mail/exim/work/exim-4.66.
    *** Error code 1
    
    Stop in /usr/ports/mail/exim.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.27123.0 env make FETCH_BEFORE_ARGS=-q
    ** Fix the problem and try again.
    
    How it can be corrected?
     
  2. nilesh_kolte

    nilesh_kolte Well-Known Member

    Joined:
    Apr 13, 2006
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Pune ,India
    cPanel Access Level:
    Root Administrator
    Hello,

    Try to reintall Perl on server. And after that run eximup force fully.

    This will fix your issue.
     
Loading...

Share This Page